Hi fellow developers,

I have a minor problem. Working on a macbook in Holland, our date format is DD-MM-YY
I don’t need time recorded.
When I select a date field to process in Bubble’s database the format is as follows:
MM/DD/YYYY hh:mm:xm
My records are filled correctly to this format.

My questions: how do I set the date time format to Dutch standards (I already gave Safari the correct date and time format according to my location). But can I adjust the date/time format in my database field to my needs?

Second when I do a search and I use a input box I can select only two formats: Date and Date 2.Date sets the format to mm/dd/yyy date 2 sets the format to not one format will find the records in my database that are set to mm/dd/yyy h:mm xm.

How can I set the formats correct where my user has to type DD-MM-YYYY.

Please help, a little bit frustrated about this date thing.

Kind regards,

Animal Rescue Squad North Veluwe, The Netherlands

Why would you want to let users type a date?

If you let your uses pick a date through the date picker element or the very nice air date picker plugin, your users don’t have to worry about date format.

As for serving it back, you can just do date:formatted as DD:MM:YYYY

Would that work?

Hi vincent56,

I already tried that but it won’t work either…

I’m pretty sure this is possible. Maybe you can share your editor or we can take it offline and do it in Dutch :wink:

I am so sick of this ‘date’ thing:

My date field in my database is format like this:
I can’t change anything to that which is stupid enough because I only need dd-mm-yy

My user sees all markers on the map while not selecting any date:

It even displays the first item in my database which is set on 20-04-2018.
Date Time Picker is set to date dutch format:
Then my user picks the preferred date:

And this is the final result:

Not even the 20-04-18 listing on top is shown. It does not see any markers with this date.
SO PLEASE PLEASE PLEASE,someone enlighten me with this Date thingy.

Last night I found out that searching for a date only doesn’t give a positive result when time in the date field is set to 12.00 am. The suddenly the date is seen as OK and my markers are found.
Please can anybody tell me what is the reason for this? A day consists of 24 hours where the same date is valid. So why can’t I select like CONTAINS my dd-mm-yyyy while time is between the range of 00.00am and 12.00pm? Is this a bug?

The hours:minute part always belongs to the date, even if it is not visible.
So as you already figured out you have to make sure the time also matches.

You can do this by either:

  • set the hours/minutes to a certain value when saving the dates, and then searching for this particular hours/minutes
  • do a >= 0:00 am <= 23:59 pm restraint in your search

Thanks Reger-Alexander,
I wish someone had told me before after spending hours on trying to find out why my searches did not work.
I hope someone will write a manual on these subjects that would help understanding Bubble better.
But now it works and I am happy again developing some nice routines for the Animal Rescue Squad.

Thanks again for your time, with kind regards,

Cornelius form Holland

This topic was automatically closed after 70 days. New replies are no longer allowed.