Delete current RG cell

Hello guys!

I have been trying to find a solution to my problem for days.

I’d like to delete the current cell from a RG when the user clicks on “trash icon”.

It looks simple but it’s not, for me at least. :frowning_face:

The thing is I have a group within my RG so I don’t have access to the current cell. And it’s a nightmare. I tried all the tutorials I could find and I’ve also searched this forum.

Some tutorials that I tried:
How to access the parent repeating group from an embedded repeating group - #3 by chad from @chad

Deleting rows on repeating group - #3 by romanmg from @romanmg

Can anyone help me ? I’m really stuck here.

What exactly is the issue?

To delete the current cell’s Line Item from the DB just use Delete A Thing, delete parent group’s line item - which is what you are doing.

So are you saying that’s not working?

When I delete Parent Group Thing it deletes all the cells except the first one. Don’t know why. Also it doesn’t update the “line items custom state”.

I have the first part of the solution to delete Parent Group Current Cell.

I use Delete Thing / to delete : Search for “Group Name”:item#Current Cell’s Index

But I don’t manage to update the custom state to display the updated data. Anyone?

You can just do delete a thing, current cell’s line item.

My dude! If you still haven’t figured this out, you need to set a custom state when the trash icon is clicked:

Clicked > Set state > select state > define the state as it currently is > minus item > Current cell’s thing!

Hopefully this reached you in time!

1 Like

Thank you! I had already found the solution.

This topic was automatically closed after 70 days. New replies are no longer allowed.