Did someone already tried the Stripe's Register as a seller?

I can’t make it work and I’d appreciate to ask some questions.

1 Like

I know that you have to set your stripe product to “live” and “testing.” Someone correct me if I’m wrong. If your account is set up correctly and verified, your product name should show up in Bubble when you use the “Get Product” command. I think that it, could be wrong.

I tried but couldn’t make it work.
My question is how do a seller get paid?
Do I have to collect their bank account numbers? Or do they have to setup their own stripe account?
I don’t really get it and would also appreciate some help.

A couple of us tried it when working together, but neither of us could get it to work.

Happy to help with where we got to, but we just always came up against “not a registered seller” error.

Thank you all.

@Tommy I’ll try in live mode and I’ll tell you back in the day.

@cho Bubble use Standalone account so you can get other sellers get paid

Then when you set up the payment, you have to check the checkbox like here

@NigelG I’ll try again and I’ll join you in copy of a support request if I can’t make it today.

1 Like

I tried but it did not work out :frowning:
I’m always send back to the URI meaning an error occurred and can’t figure out why.

It’s probably an issue in the way you set up stripe connect in the stripe dashboard. Make sure the URL is the same as the one users are redirected to in Bubble.

if no luck, email us.

1 Like

you mean that Stripe’s URI for succes/error redirection must be the same than the page’s URL where my button “Register as a seller” is ?

Yes, because that’s where we’re redirecting the seller after he authenticates with stripe.

May someone try to register as a seller please and tell me if it works ? I don’t have another Stripe account.

Of course I’ll delete the account if it works afterwards. Hopefully !

Make sure the URL isn’t https…

In the Stripe Settings, it tells you are wrong if you type an http:// URI

Have you tried though, not sure they strictly enforce that. What is certain is that your site currently doesn’t support SSL

I tried several times.
For Development Url redirection, http is alowed
Bit I could not saved an httpS Url redirection for the Live version.

here a screenshot :

Please email us for this.

We should have watched the video :slight_smile: https://vimeo.com/92872333

The issue is that the redirect URL should be https://bubble.io/poststripeauth, whatever your domain name is. Then you get redirected to your website. This point was missing in the documentation and is now added.

So no SSL is needed for our app.


Yes, we’ll update our reference on that one, sorry for not having it up there right now.


Well done guys :slight_smile:

There is one thing I don’t get. How do we know from Bubble we are on the Stripe’s Test or Live environnement ?
Have you setup things so when we are in :
domain.com/version-test/ => Stripe’s Test Mode
domain.com/ => Stripe’s Live Mode