Forum Academy Marketplace Showcase Pricing Features

“Display list” workflow action to refresh the repeating group

Hi there,

I have been facing a very bizarre situation where the “Display list” workflow action to refresh the repeating group is working fine only for the first time, but only once. Subsequently, when I hit the button on another icon listed in the repeating group, it doesn’t ‘refresh’ at all.

To explain in detail:

  1. I have a repeating group where it contains a list of data. (Data source of the repeating group is defined as below mentioned picture) image

  2. I have added a delete icon, which essentially removes the selected column data.

  3. I have added display list in repeating group in the workflow once the item is deleted so that this workflow refreshes the repeating group and shows updated list which excludes the deleted item.
    image

  4. But this workflow is working fine only for the first time. when I delete any item for the second time, the item is actually getting deleted from the backend but the Repeating group is not getting refreshed.

Is this a bubble bug? If there is a fix around this issue, please help me here.

Thanks in Advance!

Reading this makes me think it might be. I’ve been trying my hand at APIs and one set up was to refresh the RG that contained the API data after I made a change to the data used for the API.

I was noticing that the method which also used the display list workflow action only worked once. I thought it had something to do with the API and not the workflow action.

Not sure if somehow both of our cases are related to the same underlying issue around delays in data creation/manipulation though as you mention you are using a backend workflow to perform the deletion, so possible that the refresh happens before the data has been full removed from the DB.

Could be worth submitting a bug report…I’d be interested to know what Bubble support sees as the reason…because if it is a bug, it is probably affecting my app too.

Any chance running the “clear list” action before updating the list source does the trick?

image

You’re both running into the case that API connector calls are cached. If you do another call that is identical (that is, if none of the parameters in your query have changed), Bubble assumes the new result would just be the old result and returns the cached data without actually pinging the external API.

Solution is to add an extra phony parameter (like a date field) and then send current date/time or similar so that your calls appear unique.

Lots of discussion of this in past threads, which you can probably find by searching API Connector cached or similar.