Do a Search Repeating Group Not Loading, Items not adding into Database

Whenever I try to make a Repeating Group with the data source as ‘Do a Search’ and preview the page, the Repeating Group never loads. This issue does not occur with any of my other apps, just this one, even with the exact same settings on the Repeating Group. I have tried deleting the app and trying again but the issue persists. There are no privacy settings on the data.

Repeating Group settings

Repeating Group loading

If you need more information please ask. Thanks!

EDIT: Also found a new bug, when creating a new item with the workflow (clicking a button to create a new item), the item does not appear in the database.

Just want to confirm, do you have ‘News’ data items in your database?

Yes, I do have News data items in my database.

check to see if your database(s) for live/version-test has news data.

what do you mean by this? you created the app again or just copied it?

I deleted the app and created it again, since I just started on it and discovered this issue.

Also found a new bug, when creating a new item with the workflow (clicking a button to create a new item), the item does not appear in the database.

weird idk, ive never seen that behaviour before

Hi @infinity :slight_smile: Can you share a link to the app editor?

Sure, here it is:

Thanks! :slight_smile: Hmm, which browser are you using? I just previewed the page and clicked the button a few times, which created a few News Things. They’re appearing in the app and database on my computer:

Thanks for checking it out. I’m using the latest version of Chrome and Windows 10. Not sure why it’s not working on my end…

Yeah that’s definitely odd :frowning: I remember something similar happening in the past because of the style conditions on that button. Just to check, if you change the app’s style theme, is there a difference? (Standard Bubble theme for example?)

Just changed it, no difference. What’s even more strange is that the problem is local to this app only, even after deleting and re-creating the app with the same name.

That is so strange :frowning: I’m not sure what else it could be; it may be worth filing a bug report just to see what might be going on!

Do you see any errors in the JS console when viewing the page or clicking the button to add a record?

Might there be a Chrome extension / ad blocker / setting causing a conflict or preventing access?

Have you tried with a different browser?

I noticed the name of your app is “onead”, which also happens to be the name of a “money making” MLM Android app. This is pure speculation on my part, but since the issue occurs only with this app, I’m wondering if it’s related to that string being in the domain name.

Hi @infinity,

I believe @sudsy may be right as I am able to preview the RG on Safari and it works fine.

Thanks so much! It was my adblocker that was causing this. I thought I had turned it off but it turns out I hadn’t. Thanks! :grin:

This topic was automatically closed after 70 days. New replies are no longer allowed.