Documentation on list actions


Is there documentation on list actions such as add, remove, add list, set list, remove list, clear list?

I tried to “copy” a search result onto another list by using add list or set list but I’m not sure I am using the action correctly.


Yes we do :slight_smile:

Hi Emmanuel,

Thanks for the quick response! :frowning: Unfortunately, I browsed through this already and could not find anything on “add list” or “set list”…

You’re right, we don’t have that one actually. But it should be quite explanatory. Which one is an issue (we’ll add that, but not at the second)

Add List and Set List.

When I created a “search result” (which is a data type of a list of “products”), I wanted to add the search result to another list (which is a field with the field type “search result”) by using set list or add list. There was no error to my workflow. However, when i tested it, it did not work.

What do you mean by ‘it did not work’? In this case, I think add list is what you need.

What I mean by that is that the field, “current search,” which I wanted to add the search results to was empty even when I use add list. I don’t think add list is adding the list at all.

Have you tried using the debugger to make sure the search returns something?

Yes, I have actually and the search does return something. The problem was adding the search results list onto “current search.” Current search returns nothing.

You mean, after operation? Can you reproduce the situation in the forum_app? it’d be easier to debug.

How do i go about doing that? Where is the “forum_app?”

check this post Open app for forum questions

Please, what does “set list” do? Thanks

it’s setting a list of things, erasing whatever the list there was before


As a coder I’m super impressed with Bubble @emmanuel - Question: Have you guys added the capability to add multiple rows of things to a data table at once? I don’t seem to find documentation on this. If that’s not possible, how do you suggest doing that?

UPDATE: Oh shoot, looks like adding multiple entries to the database still doesn’t work :confused:

Do you a timeline on when that may become available? Here’s my use case.