DOMAIN: Bubble and Cloudflare issue

Hello gents,

First time writing, already made app based on many inputs from forum so thank you all for this.

At this point, I could not find the solution for the Domain issue I have with connecting my domain to bubble website. As my domain provider doesn’t have DNS control option I had to use Cloudflare. I setup Cloudflare DNS settings as explained in the manual:

Previously I connected nameservers between Cloudflare and my domain provider.

But then I get the message “We found bad DNS”

I waited more than 48 hours, but I’m not sure what the problem is. If someone can help me it would be really great!

Another related question: after I set this up - how do I go about using Bubble as e-mail hosting? I don’t have any hosting plans on my domain provider, only domain boutht, but since Bubble is hosting my app, does it also act as a Host for e-mail? If so, it would be very good if someone can give me some hints to set it up.

Thank you in advance!

I’m not really experienced with the Cloudfare way of dealing with domains but your first two A record hostnames should be empty, not ‘’.

Bubble doesn’t host emails, or domains for that matter. They just provide webservers you can connect to your own domains

Hi George,

They are empty, when i try to edit them I put only @ as bubble instructed, but it automatically changes to So somewhere is a problem here, if someone who is more Cloudflare experienced can help would be awesome.

Ok thanks for the e-mail reply.


The @ symbol is the domain you’re using. I’d assume your domain is “” so that’s why you see that there. I’m personally a little confused on why your domain is not working.

You did purchase a bubble plan, put your domain in the box, and put in the values it gave you?

Another Idea I can think of is adding the records it says can’t be found (The ones from the Image) into Cloudflare and trying that

Update: I tried your domain again and it took me to your bubble app.

Exactly, I did all of that.

Except that I didn’t yet purchase - I’m on trial, but Custom domain should be already included. Trial is ending in 2 weeks so then I can check if that makes the difference, but I don’t think so.

Yes, this is the crazy part: it works - it goes straight to my Bubble app.
But in bubble it’s still the same - “We found bad DNS records”.

And I can not keep it like that as I can not setup e-mail and SSL settings - unless the A records are confirmed by bubble.

So a solution is needed…

Yeah this wouldn’t make a difference.

When I first tried your domain it added some random characters so it could be a record interfering with it. You could even try to redo the domain setup and see if that gets you any solutions.

Hey, you should disable the proxy setting for your domain to work (the orange cloud icon).

Otherwise, if you want to use proper Cloudfare to integrate page speed features from the pro plan, you can use the following tips which worked for us

AWS’s Ipv6 facilities are not great and we aren’t able to resolve where the Ipv6 records go in the past. This has caused issues with certificate issuance, so we left it as an error in the current iteration of the domain checking code. Basically, our certificate issuer tries to validate every A/AAAA record, and because AAAA records don’t really work inbound to our infrastructure reliable, having any AAAA records risk breaking SSL completely. The solutions for now are, unfortunately, to wait out and re-write, or potentially try some hack to make the error go away. The last solution would be for you to turn off Ipv6, as Cloudflare exposes it deliberately only as an API call (i.e. not from the dash)

So if you want to proxy your Bubble site via Cloudflare (and you might want to, as it will act as a firewall for DoS attacks) then tell Cloudflare to translate IPv4 to IPV6 … (in Network)

And ignore the error in Bubble as IPv6 is all good.



Hey man,

Thank you very much, it worked same second as I disabled proxy!

Very grateful for this!

@vnihoul77 Thank you for your advice. I had a same issue but your solution made me free! Thank you

Happy to hear :slight_smile: