Don't understand why workflow keeps referring to "Incompatible Type"

I am new to Bubble and I feel a bit confused with sending data from an option list dropdown to my database.

I’ve created a data type called “Review” in which I created the field “review-relationship” :point_down:

The field has to be text from the option set “Review Relationships” :point_down:

Now, I created a form where users can leave a review. From a dropdown called “Dropdown Review Relationship” they can choose a corresponding option

The workflow behind the button “Submit Review” looks like this:

When I want to link “review-relationship” with the dropdown, it keeps referring to “Incompatible type” - What am I doing wrong?

Thanks for helping me out!

Hmm, well you should be able to do that. The only thing I can think of is do you have a data type named the same thing (Review Relationships) that you might’ve accidentally set the review-relationship field type to instead of the Option Set?

Also, a quick tip regarding naming conventions:

Sometimes it helps to name the field the same as the data type, and capitalise fields that use datatypes rather than text/number etc. So for your Review I might have

Service Provider
Review Relationship

as it helps visualise which data are datatypes/option sets and which are not :slight_smile:

1 Like

Thanks for the quick feedback George.
Great advice on naming fields :+1:

Regarding the Review Relationships, I haven’t any data types named like that :frowning:
I only have 3:

And you don’t have two dropdowns named the same thing? It looks like a bug but there might be something your screenshots don’t show. Have you tried deleting the dropdown and recreating it…

1 Like

Recreating the dropdown solved the issue :star_struck:
Don’t know what was wrong

So much thanks @georgecollier for helping me out!