Incompatible Type - Dropdown

Trying to filter a Repeating Group based on a Dropdown. The dropdown is based on an Option Set. Is there something I am doing incorrectly that you can see here (below) or a way around this?

Hi there, @Rob-Trading… I assume the Status field in the option-trades data type has a field type of something other than the option set (like text)? If so, you will need to delete that field and add a new Status field that is linked to the option set.

Oh, and not to be too nit-picky, but its “ideal” if you don’t pluralize your data type names because Bubble attempts to pluralize them for you as you work with them (hence the double s in the data source).

Hope this helps.

Best…
Mike

Thanks for the quick reply! I removed the extra “s” from the data name. Thanks for that!

Also, within the structure, the Status field is linked to the Status option set, not text. See below.


Okay… what does the setup of the dropdown look like?

Looks good. I’m not sure why it’s saying they are incompatible, but I think I have seen some other folks running into anomalies like that recently. Maybe try deleting the dropdown, refreshing the editor, and adding the dropdown again.

Was the drop-down copy and pasted from a UI chrome extension like frames or basis? I have found that sometimes when I copy and paste a drop-down from UI chrome extensions that it causes these types of issues.

Maybe try with a fresh bubble drop-down and see if it works?

That was the issue. Not exactly sure why, but deleting and re-creating the dropdown worked. Thanks!

1 Like

@Rob-Trading if you run into this again, please submit a bug report. I submitted a bug report about this. I have experienced this in every app that I have worked on the past few weeks. I reported a Bug about this on November 12th.

Easiest way to resolve and be able to move forward with your work when you experience this again is to refresh the browser.

It happened to me after changing a searchbox into a dropdown
After a refresh of the editor page, the bug disappeared