Download a CSV File

Hi all,

Having trouble with the ‘download a CSV file’ function within the app. I can download the CSV file from the backend Database and it formats perfectly fine, but the same content downloaded from within the app comes out with unique values as opposed to the actual formatting.

Data exported straight from Database

Data exported through the app

There’s got to be a simple thing I’m missing here! I’ve tried to define the values which has worked fine for the database download. I’m not 100% sure if I can define the values for the ‘In App’ download, but I’m guessing that’s where my issue is!

Thanks in advance

Ok, this is pretty tricky (and a big source of frustration in our app). The short answer is this: CSV downloading from the app itself is rough around the edges. Check out this thread for a work around:

It’s not great, and we had to actually remove the feature from our app as the downloaded CSV was too complicated for our users, but this will be the starting point for you, I believe.

Perfect really appreciate your help!

I’ll give this a go :slight_smile:

Reopening this question,
I have read the linked answer but it seems to be really complicated for a “small” problen. Does somebody have a quicker solution ?