Forum Academy Marketplace Showcase Pricing Features

Dynamic text fields disappearing - can't figure out why... Any ideas?

Hi,

I am having an issue with dynamic text fields disappearing, and I can’t figure out why. It has only just started happening - previously this wasn’t happening.

Here is the problem…

Here you can see the fields (in orange) which are the Current User’s First Name, Last Name etc.

Here you can see the workflow I have - update the record, then reset input field. This also updates the dynamic text in real time.

Here you can see that, when I preview, it has the data populating the dynamic text fields (except the last question which I haven’t answered for the first time as yet.

Here I am updating the first name field using an input text box.

Once I have submitted the new text, the details change on screen (the orange dynamic text fields) but after about half a second, all of the dynamic text disappears - including the dynamic text in the green banner. I have tried having the dynamic text in buttons as well - but the same thing happens.

If I close the page, and then preview again, you can see that the data has updated (new first name is there). But if I update any fields again, the same thing happens.

This is really stumping me. I have tried deleting users, registering a new user and starting again - and the same thing keep happening. As I say above, it wasn’t happening previously, so if anyone can explain how I can fix it I would be most grateful.

Thanks

Andrew.

Use auto-binding instead of changing the database when the value changes.

I assume your issue has something to do with the fact that any change (including erasing the input’s value to type a new one) triggers a database change. Autobinding the input is the way to go here.

1 Like

Was this solved? I’m having the same issue.

When a user signs up, a “signup popup” goes away and index page is displayed underneath. In the header, “User’s First Name” should be displayed. It’s not. However, if browser is refreshed, it works.