Enable auto binding for a custom state

I am working on food recipe app and i am facing some challenges especially when i try yo edit each recipe :

1- why multi drop down not display ,although i checked the "Auto binding " ?

2- Why after i try to edit the recipe , the costume state not edit too or even not add new images

3- the slide show not display all the images " ONLY 1 image " ?

Thanks in advance and any help really appreciate it

Custom states (aka Bubble’s dumb term for local/page-level variables) cannot be autobound. It would make sense for that to exist, but that’s not currently a feature.

So, you mimic that behavior by updating the custom state any time the input tied to it changes. (Using a “When an input is changed…” workflow.)


Hi keith , thanks for the reply , actually i think i am using a work flow here to edit the custom state , by adding /delete new images , create new data then set a state , but it looks like i am missing something here , for example the old data not display in the repeating group such as the images i have added when i created the recipe , even if i try to add new images after click on the edit icon , it still not working !!

i have solved the slider issue , what really confused me is that when i try to edit the images in the repeating group , i have done the same steps i did when i try to add new images , i mean if i click on " Add new recipe " i add a new recipe images using my custom state , now if i click on the "Edit button " and try to do the same steps " adding new images using custom state " the images not display on the repeating group !!!

2- i have checked the " enable auto binding " for " MULTI DROP DOWN INGREDIENTS " BUT it didn’t show !!

any help much appreciate
Thanks in advance

when i click on the edit button and try to add new image in the repeating group it works fine , but if i try to remove image deleted from the data but the delete icon still exist and it seems like the RG still count the deleted images as if it still exist !!! even after i click on “UPDATE” button nothing change in the old data !!

when i click on I"Inspect" it show me that image source is empty !! [ ONLY image i added recently "edit " images

any help much appreciated
Thanks in advance

i found the solution in this link : Delete image not disappear from repeating group

This topic was automatically closed after 70 days. New replies are no longer allowed.