Forum Academy Marketplace Showcase Pricing Features

Error 401 connecting a simple API - Works in postman, not in bubble

Hi, I am trying to connect this API GET call: Edamam Food Request Step 1 - Parser click to see docs

However, I have not been able to initialize the call because I get this error:

This is how I have my settings:

I have checked the key and the app id many times, they are correct. I have tested this in postman and it is working properly there.

I tried deleting the

(Accept application/json)

header and it does not works either.

I also tried adding the parameters as regular (not query) parameters but it did not work either.

I also tried adding the key and the app_id as header and it did not work either.

Any ideas on how to fix this?

It would be much appreciated, thanks!

Where are the parameter keys? Shouldn’t it look something like this?[app_id]&app_key=[app_key]&upc=[upc]


1 Like

Hi, yes I missed that! I thought that putting the params in [] was all I had to do.

So now my request url looks like this:[app_id]&app_key=[app_key]&ingr=[ingr]&upc=[upc]&nutrition-type=[nutrition-type]&health=[health]&calories=[calories]&category=[category]

However, it now shows another error:

What could be happening here?

Ok I found what was wrong. I just had to put data into the parameters to initialize the API.
Thanks for your help! @lantzgould

1 Like

Hello @lantzgould @pachocastillosr I can’t seem to see the page when I click the links mentioned here. I also have an issue with this API

Hi, clicking that link won’t work cause it is intended to be accessed via api. I’d suggest you to read or watch videos on how the api connector works.

Thank you

1 Like