Feather Icon Issue

Is anyone else having issues with Feather Icons today? I have been using them fine and all of a sudden today in my test environment my icon is changed to a heart no matter what “type” I pick. Below is the debug of the icon. As you can see the type is arrow-up but for some reason there is an Icon name of heart. I’m at a loss on what to check. Like I said nothing changed from yesterday to this morning and its only in the test environment (I have not pushed a change to live today).

Hey!

I just went onto a test app and used the plugin and it seems to be working as expected for me. I tried to duplicate the use of the plugin as much as possible by creating a conditional that would not be true.


Could you upload a picture of the element properties window? This:

And then the conditionals?

Other than something in there that could be causing it, I would recommend the basic first line troubleshooting such as deleting that element in the RG and placing a new one. Possibly try to remove the plugin and re-add it.

That about completes my best guesses :joy:


Thanks,
Drake
Afterthought System

Thanks for the help. I just tried deleting the element and re-adding and it did not fix the issue. I cannot afford to replace the plugin as I have a bunch of elements accross my app that use feather icons. For some reason its just this one that is broken (also the only one that I change the type by condition).

Below are the screenshots of the appearance and condition tabs. Interestingly my options on the Appearance tab seem different than yours. Maybe its because I am using a style. I did confirm I am on the latest version of the plugin (1.1.0).


image

I did figure out a workaround that solves the problem which was to create an opposite condition that changes the type. So now my feather icon type is always set by a condition instead of the type on the appearance tab. Annoying but works.

1 Like

I experienced this again with another feathericon in my app. I believe its a Bubble bug when using conditions with feather icons. The work around is to set the “type” in every condition.

I had this recently when I checked it out for the first time but uninstalled it as I thought the plug-in was built that way. In preview I saw the correct icon but in the editor it showed the same icon image irregardless of the selection made.