Filtering Repeating Groups using a Dropdown

I am facing an issue related to filtering of data in a repeating group from a dropdown.

I have a static dropdown which provides the following options

  1. Prospect
  2. Engage
  3. Dynamic

Now I am trying to filter a column called name in the repeating group which contains the data like the following examples

  1. HERB_2789_Prospect_New_Dresses
  2. HERB_2789_Engage_New_Dresses
  3. HERB_2789_Catalog_New_Dresses

Now when i try to filter by the condition “name contains Prospect”, I am not getting any value in return, the repeating group is turning empty.

Can someone help me with a solution for the same? I am not sure where I am going wrong here!

Thanks in advance for the help!

Hi @sriram :slight_smile: It sounds like your setup is correct! Can you share a few screenshots of your dropdown and repeating group setup? Or share a link to the app editor? (You can temporarily set your app to public by going to Settings --> General --> Application Rights --> Everyone Can View/or Edit. Then copy+paste the editor’s URL In a new reply here)

@fayewatson Thanks for the quick revert on this.

The below mentioned are some screenshots for the same.

  1. Repeating Group Setup

  1. Dropdown Setup

  1. API response

Hope this helps!

@sriram No problem at all! :slight_smile:

Just to double-check, there isn’t an extra space after “Prospect” in the dropdown or in the default value “Prospect”?

If not, if you remove the first constraint temporarily (bubble_configured_status = Dropdown Status’s value:find&replace), do any of the Prospect matches show in the RG? (Just curious since the name constraint part looks correct!)

I tried the same, But there seems to be no space before and after the word.

I even tried to manually enter Prospect instead of Dropdown to test the same despite that i am not getting any values in RG.

Is the name parameter marked as private in the API setup? If so, is there a difference if you uncheck private? (Also not sure if that would make a difference?) I did a forum search and the post below states that Facebook previously prevented filtering on some of their APIs. It looks like all was fixed a while ago though, but it may be worth it to send an email to support just incase?

@fayewatson Thanks for all the effort you have put in this. I checked if it was in Private. It is not having the private condition checked.

Also regarding the Facebook API, this particular RG is not getting rolled up from a Facebook API.

Anything else which you could think of which could help me solve this issue?

@Bubble @sridharan.s @NigelG

I’m sorry I’m not sure what else to try :worried: hopefully another Bubbler has answer, but if not - I would send Bubble support an email just incase!

@sriram Enable ‘ignore empty constraints’ in case the filter condition isn’t met. If you are still running into issues, please submit a bug report.

This topic was automatically closed after 70 days. New replies are no longer allowed.