Font Awesome Icon [text] not showing in repeating group


My RG is not showing an Font Awesome icon within a repeating group. Please could somebody have a look as to why it’s not working in this App? I’ve tried in another app and it works.

Editor here -



Its your database

put space between brackets and the fa-icon and put fa

@boston85719 - I’ve updated but still isn’t working. See screenshot below. Same editor link.

I’m not sure what is going on…it is hard to test out things or fix them without access to make changes.

I’d play around with it and remove the original text element and add a new one…doesn’t look like anything is wrong with it because the text property shows the correct formatting.

Try a text element on the page not in the repeating group and see if it is working by just adding [fa] fa-home [/fa].

If that doesn’t work in a single text element on the page, there is something wrong that may require a bug report.

Text element on the page without the RG worked… Does this help diagnose?

How do I go about requesting a bug report.

@boston85719 Forgot to tag, see above.

If it worked, then I don’t think there is a bug…what I would do now is remove the text element you had in the repeating group before and place the one that works from the page into the repeating group and don’t change anything to the text element.

If every cell displayed shows the same icon then you can set the dynamic expression in the text element to match the current cells icon…the reason to do this is to isolate if the problem is the text element in the repeating group or if there is something else that is wrong with the way the database is set up.

It could be that in your database you do not want the [fa] [/fa] so that when creating the dynamic expression in the text element in the repeating group you would do

[fa] current cells icon [/fa] and in your database remove the [fa][/fa] and only have fa-home for example.

@boston85719 - Check the editor link. Basically, the text which has [fa] fa-twitter [/fa] as a text element in or outside of the RG shows up as the correct icon in the editor mode but doesn’t show in the preview mode.

Dynamic icons within the RG don’t show, even if I place the [FA] outside of the DB.
Editor View

Preview View

It seems to be an issue on the preview side

I’d report it as a bug then

This topic was automatically closed after 70 days. New replies are no longer allowed.