Geographic Places not Populating in Search Boxes

A couple days ago the Google Maps API randomly stopped working in some places in our platform.

Failed Attempts

  1. I’ve read dozens of Bubble forum articles, trying to find a solution, Nothing.
  2. I’ve regenerated the google API key and swapped it out in Bubble. Nothing.
  3. I adjusted the API restrictions on google’s side, and eventually removed all restrictions to eliminate this as a possible issue. Nothing.
  4. I deleted plugins that use the maps key. Nothing
  5. I deleted and rebuilt geo search boxes that aren’t populating. Nothing.
  6. Updated payment information in Google. Nothing.

Additional Symptoms.

  1. Some search boxes are not populated with locations when a user starts typing.
  2. The issue is not consistent for users for a given search box, meaning some boxes don’t work for some users and do for others.
  3. The issue is not consistent for dev or prod for a given search box, meaning some boxes don’t work in prod and don’t work in dev. And visa-versa.
  4. The issue is Interment for a given search box, meaning some boxes stop working, and other some start working again.
  5. If there are multiple search boxes on a given page they either all work or they all don’t work.
  6. The browser’s UI console has the following errors, regardless if the search boxes are functional.
    *A “[Warning] Google Maps JavaScript API has been loaded directly without a callback. This is not supported and can lead to race conditions and suboptimal performance.”
    *B “You have included the Google Maps JavaScript API multiple times on this page. This may cause unexpected errors.”
    *C. “[Error] Geocoding Service: cannot connect to the service, please check the Geocode API key”
  7. This has happened in the past, and the issue eventually resolved itself.
1 Like

I am having the same issue! I tried regenerated the Google API keys and the search box worked for a moment (populating locations) but then it doesn’t work again.

Hi @jeallison , how are u doing? Hope it’s fine

So, in my app is currently having the exactly same problem you are facing. Have you guys found a solution for this?

One thing that might help (it helped a little bit for me) is hidding the search box unless the element is visible (in our case, the element is a RE popup).

Not always resolve the problem, but somehow mitigate a little.

All the symptoms you showned we are currently facing, so anything that helps would be great