Getting never before seen errors now

My app is live in a certain state, and suddenly I’m getting errors on elements that I didn’t touch. I had one before about referencing its own object or something along those lines that I saw a mention of in the forum.

Now I’m getting this:

Data source cannot use an element that refers the the current element, in conditions.

That sounds clear, but I have no idea why this is an issue now. It clearly wasn’t before because this is what is now live.

Did something change in the Bubble backend that causes these issues to pop up? I’m also not seeing what the problem is here.

What worked previously was to just clear the dynamic data and redo it, so I’ll try that to see if the error goes away.

Anyone else experiencing this?

I couldn’t redo the data source like this, instead I had to change it to a ‘do search for’ which is unfortunately slower in this case. Very strange that this is now impossible… I just hope this error won’t be popping up in other rg’s with the same setup!

We indeed just pushed an improvement to the issue checker that catches stuff that should have been caught a long time ago. A repeating group data source should not use the same repeating groups list. Fixing this will make your app more reliable and faster.

1 Like

Sorry, I don’t understand.

I have a condition on this repeating group because of this design, that is on the roadmap to be changed:

Make the new default for searches be that null constraints AREN’T dropped

I do not want to show files if a constraint is not met since that is a potential security risk.

So what I cannot do is say:

when parent group’s X is not empty > get me Parent group’s X’s Y

But I can set the same condition only with a ‘do search for’, which will get me the same result?

I will dig to see if I can find that previous issue, but I’m pretty sure that went away after just resetting the condition, not actually changing it.

@emmanuel With the new issue checker, I’m getting an error that was previously causing a bug. This is indeed occurring when I reference the repeating group’s own list as its data source.

What I’m trying to do is sort the repeating group results based on clicking an element - sorting from low to high and vice versa. Is there another way to change the sort order of the same list without changing the actual data source? The reason I built it this way is so that any other parameters already in the data source wouldn’t change when the group is sorted.


1 Like

Nevermind, found that I was able to fix this by using “Display List” as a workflow!

AH, this explains why I was seeing the same error after coming back in, thought I was going nuts! Fixed it now.

Love that this forum is prompt. Nearly lost my mind as I saw new issues w/o having changed anything.

I have a list (repeating group) that is currently being sorted by the content of a dropdown. I’m not sure I understand the workaround. Can someone clarify?

36 PM

Second this. I’m having the same problem.

You can just redefine the list as you did in the first place in the data source section of the appearance tab, and the little difference with be the sorting field. This will make display faster (in addition to removing the issues)

1 Like

I’m all for making my app more reliable and faster, but I do not understand why my initial setup would be a bad choice. Could you elaborate please? Or would I now just be able to remove the condition altogether?

1 Like

If you define the data source of the repeating group in a condition as the list of the repeating group with a sorting change, for instance, this can lead to an infinite loop, which will make the app non responsive. So instead of doing:

  1. in Appearance - datasource == search for things
  2. in condition - datasource == this repeating group’s list of things:sorted differently

you can do

  1. in Appearance - datasource == search for things
  2. in condition - datasource == search for things:sorted differently

You can use a repeating group’s list of things in other elements, but not in the same element. does that make sense?


This makes total sense, but this is not my situation :stuck_out_tongue:

I do not have anything in appearance for the element I got the error.

Instead I only have a condition that looks if the Parent group’s X’ Files are not empty and only then there is a data source.

What I don’t understand is that I cannot do:

Parent group’s X’ Files

But I can do:

Search for Files where X is parent group’s X

You’re right, this is a glitch in our logic, we’ll fix this today.

1 Like

Thanks a lot for clarifying!

To achieve paging, I use repeating group custom states to store [Items from #] and [Items until #]

capture bug.

Getting the error as well, and there is no conditional search here.

Same reason though, it’s because the element is self referential. You’ll need to change the way you’re getting the data source. What worked for me is using a workflow instead of the data source input on the Appearance tab like you have. Good luck!

I understand, but the difference is that it’s not self referential in terms of data source, which I understood could cause an infinite loop.

I have countless repeating groups relying on their own custom states to sort and filter.

A custom state shouldn’t be an issue here. if it is, please file a bug report for us to look into it.

1 Like

I am Now just getting this error on one of my pages and can not for the life of me figure out why!!

I have a Yes/No custom state on the repeating group and if a text is clicked it changes the custom state to yes or no.

This changes the data source using a search to sort and filter the data.

Why is this an issue?

Can you file a bug report so that we can have a look