Forum Academy Marketplace Showcase Pricing Features

Group transitions in mobile

Hey, in the bubble mobile app when the you run your app, it individually hides and shows every element in the workflow. Almost as if you’re watching a slideshow, is there any way to trouble shoot this? Or does it go to being normal once submitted to Apple

@emmanuel @csblack @natedogg @NigelG

I haven’t experienced any similar issue. Can you post a link to the editor?

Okay, so what do you mean shows and hides everything as if you’re watching a slideshow?

The only thing I notice is a slight delay on showing Group Sign Up. Is that what you mean?

on a laptop/desktop computer it has normal transitions. When I’m running the app on bubble’s mobile app it looks like a slideshow as groups transition

Ah, I see your problem.

When a button on the navigation is pressed you’re triggering a workflow that has 13 “hide element” actions. You really should only be using 1.

Here is how you clean this up.

Set a state (text) on index called “page” (or whatever you like). This state will determine what is shown on the current view. Then, when you press a button on the nav bar, set the state of the page to the relevant view (i.e. “home” or “messages”, “notifications”, etc.)

Then set all your groups to be invisible on page load. Use conditionals to show a group depending on the state of the index.

Let me know if that doesn’t make sense, or if you have questions.

how do i set a state on index?

Create a custom state on the page.

@csblack ok so i set the state but what goes after that? The issue says that it has to be “yes” or “no”

I’ve recreated this in the forum app.

You should be able to inspect the different groups to understand what I mean.

https://bubble.io/page?type=page&name=customstateexample&id=forumapp3&tab=tabs-1

aw man thanks @csblack ill let you know if i have any questions

1 Like

ok so quick question, is this how im supposed to use this custom state?

@csblack because im trying the same workflow you had but its now working

No, uncheck the box on the group that makes it “visible on page load”. Then delete that second conditional. There is no need for it.