Help with some DB Issues

Hello all

I was wondering if someone can help me with an issue I have with a Work Order app I’m trying to make, I’ll explain…

I have 3 data types

  1. Client
  2. Order
  3. User

The problem is when I make a new order, the new order gets created in the DB no problem, but the Order List Field in the “Client’s Thing” can not get updated, I have tried many things, watched many videos, read many entries in this forum with no luck.

I’m new to bubble and I was under the impression that when I create a new order entry and because the data types being linked by the filed types it will automatically make changes to the Client’s Entry, once I realized that it doesn’t I tried creating a workflow to make “changes to a thing”

I have tried so many things, and basically, always get the same errors

Make Changes to Client…: value should be Order but now it is a text
Make Changes to Client…: value should be Order but now it is a number

You’re trying to add the input value (which is a text) to a field which should be an ‘Order’ (hence the error message).

You need to add the actual ‘Order’ to the client’s list of orders, not just the text input.

The easiest way will be to refer to the step in the workflow where the order was created.

So assuming step 1 created the order, in step 2 you’d want to make changes to the client, and add the result of step one to the client’s list of orders.

If you’re not updating the client record in the same workflow as the order was created, then you’ll need to do a search for the specific order that you want to add, with a constraint for it to match the order’s order number.

The the primary Display fields are setup like this

Order DB new entry looks like this, see the image below, when an order gets created all fields are populated correctly.

Client entry files look like this:

the fields marked in yellow I can not get them populated

The create a new Order workflow looks like this, no errors

The make new changes to Client workflow, to populate those fields marked yellow above, looks like this:

it generates 2 errors

Thanks in advance for any help you may provide.

These are the steps in the workflow

Thanks, it worked!!

this is the changes I made to step 2

Perfect - glad you got it working :slight_smile:

Thanks for your help, I really appreciate it

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.