How set more than one filter simultaniously

Hello, I need to set two different filters for my Repeating Group which displays Sales records, but I need them to respect eachother.

In my example, the “Sales Records” repeating group has the columns: “Customer”, “Product”, “Revenue” and “Profit”.

I did set easily the two first filetrs (for Customer and Product columns), but I need them to respect eachother, so If de user have selected one option in one filter and then select another option in the next filter, I need the displayed list of the RG to filter the data according to all the filters and not only the last one.

I tryied this with “Only When” in each filter’s Workflow, but this didn’t work when one filter is emtpy (not selected any option yet by the user). Maybe I’m not using this feature right?

I’m not sure what you mean by ‘Each filter’s workflow’… but just add the ‘filters’ as constraints on your search.

1 Like

Although I don’t 100% understand what you are looking for, my first suggestion is:

Try checking “Ignore empty constraints”.

Screenshot 2023-09-24 at 7.13.24 PM

When you are building your search for your RG, build it so search on BOTH of the criteria you’re talking about. But also check the “Ignore empty constraints” checkbox.

This way, if they enter in a Customer value to search on AND a product, it will search for both. But if they enter in a Customer value and no product, it will search for the customer value.

Hopefully this helps.

You could add states to enable or disable the filter, and search throught these states
Let’s say the states:
Customer’s filter? (type customer)
Product’s filter? (type product)
Revenue’s filter? (type number)
Profit’s filter? (type number)

Then Do a search but using these states. You should ignore empty contrains too.

If you want to change the filter, then change the states.

1 Like

This was exactly was I was looking for. Super simple, that option was like invisible to me, thank you @firstfifteensoftware.

Thank you for your reply, it also works, but in the end all I needed and was omiting was the option “ignore empty constrains” :man_facepalming:

Thank you