How to change Page ID?

So, when I started creating this app, I gave it a dummy name “T65”, thinking that when I actually named the app it would change. However, the “Page ID” even after publishing, linking to my domain, and changing all the page titles, still appears as “T65”, even on Google.

In the editor, the “Page ID” in the URL shows as T65, even though the name of the application is different.
So, is there any way that you can change the “Page ID” to something else?

@jcindy81 - there are the only two options I’m aware of:

  1. If you’re not on a paid plan, create a new app by copying your existing app.
  2. If you’re on a paid plan, you can go to Domain/email screen below and change your ID (url). Example below is what’s shown when not on paid plan.

Try to double click the page to open the page setting dialogue then change the title at the very top

@jcindy81 Also make sure whoever you’ve registered your domain name with is setup correctly

I really appreciate the replies, however, it doesn’t look like these solve the issue. I am on the paid plan, so copying the app isn’t an option. Under the domain/email screen my URL is the web address, which shows up fine. It’s the actual title of the homepage that will not change. The actual index page name has already been changed. See attached, but the page itself when shown in search results always comes up as the old dummy name “T65” that the app was created under.

I’m assuming you pushed the Page title change to the “Live” environment, right? Offhand it looks like you have it setup correctly (I have apps setup similarly and they work as expected). Not sure if it’s a google thing where they have T65 cached in their algorithms. Did you recently (last 24hrs) make this change?

Thank you. Yes, it’s been updated on live for about a week. I just noticed the dummy title when it came up on a search a week ago, and have been endeavoring to fix it since. Maybe I just need to be patient and let Google do its thing.

When I try looking at your website via Google, it includes the snippet below.

Based on the snippet, I’d say it’s a caching issue. And the cached information is based on the application not being able to load. Perhaps you had added the domain but not yet pushed to live? Can’t think of why you may see that error (unless Google happened to crawl your site when Bubble had an outage, which seems fairly unlikely).


That was actually because the sitemap was not visible in the SEO settings, so Google wasn’t able to crawl it. I noticed that was switched off just today. Oh, the little things we overlook.

Glad you’re making progress. Be sure to follow-up here with any updates/outcomes. A bit curious about this as well.

I have today exactly the same problem that @jcindy81 reported a year ago.
Moreover, every new page I create has its name defaulted to the old app name. @emmanuel and @josh, how difficult would it be to fix this?

I’m my case, it was my own fault. I overlooked the expose sitemap setting in the SEO settings. That fixed the issue.