Forum Academy Marketplace Showcase Pricing Features

Incompatible Type - Bug?

Afternoon,

I have a form on my app that allows users to submit information to my App Data.

The workflow I have set up appears to be correct, as it’s taking the user’s information from various inputs and storing into my App Data with no problem.

However, there is one drop-down input that is not storing the data, or allowing me to set it up as such, as it is an “incompatible type”

I have a funny feeling that it has something to do with the 27,000 app data entries that is connected to this dropdown menu. I think I read somewhere that the dropdown input can only show you 1,000 app data entries?

I have tripled-checked my other dropdown inputs (with less data entries) and those are working perfectly.

While I don’t expect my users to scroll through 27,000 lines of data in a dropdown menu - later in the development of my app, the user will be connected to one of the 27,000 entries through field-type - and hopefully the dropdown input will automatically select the data entry that is connected to the user.

But at the moment, I am testing the forum submission without a user account and just wish to manually select the data entry via the dropdown.

As a solution, I tried changing the dropdown input to searchbox, but it is still saying it’s a incompatible type.

Can someone please tell me what the best approach is - to allow me to select from 27,000 data entries in an input and submit that information to my App Data.

Many thanks,

Mike.

Can you use the Input Search, with the dynamic choices tied back to the data source.

3 Likes

Another approach would be to put your data into a repeating group with a option/check box next to each item. Connect it to a search input field and then use what they select.

2 Likes

Hey Mike,

So you’ve got the autocomplete search box set to the data type of these 27k entries - what’s the type? Town/City? Is your Town/City field in the Empty Journey Detail also type Town/City? or is it a text? Match up the type of the input to the type of the field and it shouldn’t give you any issues. The value would be “search input’s value”

2 Likes

Thank you @DaveA @john3 @romanmg - I have tried Dave, and I will try the repeating group John

@romanmg I did think the error would have been along those lines. I’ve followed your post (I hope) to the letter, but still can’t figure out why I can’t set the value to “search input’s value”. Do you think it might be a bug?

Ah, I see it. So where you’re setting the value (and it’s currently in red), you don’t want “search for UK-Town/Citys” … you want “SearchBox Town/City’s value”

Almost there!

1 Like

Thanks again @romanmg but that option is shown as incompatible type. Its only “Do a search for” that is available, along with some other values.

The app is very basic just now, with only this workflow in place, so I can’t find anything that might be conflicting with it.

Could you share a link?

K, I’ve made it public and hopefully this is the correct link to share?

Fixed. I’m not sure if there was a bug or not, but I removed and re-added the town/city field. It seemed like it wasn’t showing up for you (when it should have) and then it was. I can see how that was probably super confusing… should be good now. If it starts to happen a lot, file a bug report.

1 Like

That’s brilliant @romanmg

Thank you so much. I will need to keep that in mind next time I am trying to troubleshoot. :grinning:

Thanks again.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.