Forum Academy Marketplace Showcase Pricing Features

Incorrect numbers CSV upload

Happy New Year, everyone!

When I’m trying to upload a CSV-file which includes numbers in it (e.g. 25,44%) - bubble splits the number by comma (25 / 44 separately) and puts them in different columns.

When you create CSV file from e.g. Excel: all such numbers / text with commas are automatically put in quotes (“25,44%”) - so I suppose Bubble needs to understand it and don’t separate numbers.

I’ve tried other separators, and, yes, I could manually add “|” after each entry and then export as TSV from Google Sheets and then upload it to bubble, but it’s too complicated.

At this stage we don’ handle well percentages, so you should make them 0.2544 in Excel (we don’t have a percentage type anyway).

Hi, Emmanuel

Thx for the answer.
My concern wasn’t about percentages (it was just an example), but about general CSV upload problems.
The same above-descirbed problems also apllies to texts, containing commas.

I mentioned about this issue about a month ago as an email.

Since I am the one creating the csv files, I just changed it to pipe “|” as a solution. But if you are getting the csv file from someone else, you are in trouble.

It does feel like a bug to me since the screen does have the following…

Why have the “data wrapped in quotes” checkbox" if not for bypassing “commas” inside the quotes as a delimiter?

Yes, screen does have it, but I tried and it didn’t work.

Anyway. Thank you for an idea - I didn’t know that there are other separators available and just googled it. But as far as I see it’s only possible to change separator in Excel, not in Google Spreadsheets.

I know it doesn’t work. That statement was for Bubble team. Not for you. I was asking why have the “quote” checkbox on the screen if it doesn’t work.

Use the “tab” separator in googlesheets. Bubble has that choice on its list.