Increment field value of type number

How do I increment a numeric field? I mean, something like myField += 1.

I’ve seem some examples on the forum using myField = currentCell’sValue + 1 but in my case it is not a repeating group.

I thought about myField = “Do a search for (this same row again)” + 1 but I feel like I’m loosing something. Also, it should consider 0+1 when the item doesn’t exist and it is being created. Any idea?

Can you reproduce the situation in an opened app? Otherwise it’s a bit hard to help.

Why not give CoBubble a shot at this? We’d love to help! :slight_smile:

@mario1 did you figure this out? i’m in the same situation. tried a workflow: change thing: field = search this field + 1 but not working.

If you are doing “Make changes to a thing” … then you know the thing you are changing ?

1 Like

@roddi, @NigelG is right. I tried now and it is possible, I don’t know why I wasnt’ seeing the option “This childTasksAmount” before or if it is something new because before the only way that seemed possible was repeating a search in the attribution. I just saw now that it is possible to increment but I did not test as I’m not using this anymore on my app and I’m curious to see if it would create a new correctly with value 1 on the incremental field.

Hi! How do I do this for a repeating group (i see the original poster did not use a repeating group)? I have 2 checkboxes (one on the left and one on the right) that each correlate to a different field in the database. Furthermore, the location of the checkboxes in the repeating group does not equal the same location (column-wise) of the fields that each checkbox correlates to (this is because the repeating group uses a different database to be structured. If you know of a way to structure a database’s fields besides alphabetical order, that would help). How can I assign a checkbox in the first row of the Repeating Group to column 1 of the field that I am trying to update, and the 3rd row of the Repeating Group to update column 5 of the field that I am trying to update?