Forum Academy Marketplace Showcase Pricing Features

Input element changes screen size in mobile

There is this property of input elements (e.g. multilineinput) that whenever you click in the input to start writing some text, the screen zooms in and focuses on the input. I do not want this to happen, i.e. I want the screen to keep the same size as before, since the user would now need to zoom out to see the complete screen again. try this example in mobile:

is there any workaround to this behavior? thanks

Add this to your page header

<meta name=“viewport” content=“width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no”/>

1 Like

hey @jared.gibb thanks for the reply
I copied and pasted the html you sent, but the problem seems to persist, at least in my iphone 5se

Bummer.

As a point of reference, when this is shown in a webview in a mobile app, the screen doesn’t pinch. But it could be a setting on the webviewer in the app wrapper. I’ll get back to you on that!

1 Like

Have you tried checking the box in settings > prevent zoom? This should negate that zoom in on input feature.

2 Likes

@lantzgould wow it does work. many thanks :slight_smile:

This topic was automatically closed after 70 days. New replies are no longer allowed.