Input in Repeating Group only Clickable in First Row of Repeating Group

I have a repeating group in which there is an input into which users type the number of an item they wish to order.
The Repeating Group is based on a list generated using List Shifter (because it needs to be a merge of two other lists including duplicates)
My problem is that something is preventing users from being able to change the value in all but the first row of the repeating group. Can anyone suggest what I need to change so that all the inputs in the RG can accept a value?
I feel it’s something straightforward that I’m missing as I haven’t come across this before…

For what it’s worth, here’s a screenshot of the design of the RG and the Input

Screen Shot 2022-09-09 at 10.51.57

Can anyone suggest what might be going on here? Many thanks in advance…

Hi there, @joefarrowsmith… it’s going to be difficult for anyone to help here with the information you provided, but any chance one of those four conditionals on the input says when the current cell’s index is not 1, the input is disabled? Okay, I ask that somewhat jokingly because I’m sure that’s not the case, but what are those conditionals?


Hi Mike
Here’s the conditions. I think they’re pretty benign…

I appreciate your input and, in the past, I’ve been guilty of some cringing mistakes!
All the best

Yeah, I figured as much. Any chance inspecting the input with the debugger can give you a clue as to what’s going on?

The debugger isn’t a great deal of help because nothing shows when I change values and changing values in the rows beyond row 1 does nothing either so there are “no steps” as it were.
Here’s the design of the app…

I think that provides access to have a look. Do let me know if not (it’s a bit of a mess!). The issues are on a PopUp called “PopUp Redeem_User” and the input that is giving me trouble is in the RG All AvailableProdQtys
If you get time to have a look, I’d really appreciate it. Many thanks

There must have been something on top of the input and/or repeating group (although, I can’t figure out what it was because, as you said, it’s a bit of a mess in there :slight_smile: ), and bringing the input and its group to the front seems to have fixed it. Is it working for you now?

1 Like

Oh wow! You absolute star! Thank you so much. I’m sure I even tried “Bring to front” but to no avail.
(I’m planning on making a “tidy” version of this one day. Just need to get this working now then I’ll get onto it - I never thought I’d get this far if I’m honest! And I wouldn’t have without people such as yourself.!)
All the very best

1 Like