Is ":Filtered" broken while used in Back End Workflows?

All of a sudden using Search for a thing and using :Filtered:FirstItem instead of the usual criteria stopped returning results. It used within a step of a BackEnd workflow.
Anyone else have noticed that?

Regards, Alon

Most likely the Search part is timing out before anything can be filtered. Has the number of things being searched grown? Is your app using more capacity than in the past?

Anyway, you can trigger your workflow and inspect your logs to see what happened.

1 Like

No change in # of things. Mere 6 of them. No capacity issues. Log shows the specific item is not found.
I have changed to regular search criteria and still not found. Now that is weird.
I will change the search criteria to find a specific uniqueid.

No changes in privacy rules?

If you could share some images with us will be nice!

No. No change there. First thoughts went there. It is a thing which has no special privacy rules.
Here’s the latest I am trying. The BE workflow if call externally through API.

That actually worked. Apparently I have some issues trying to match a text field that is passed through an API. Perhaps some extra chars are being added which prevented the match … Still looking into that direction…

i sometimes use text: trimmed or find & replace to get rid of spaces

Yea… I will suggest the same. If you don’t expect to receive blank spaces, just use “Find & Replace” to make sure you are replacing the space by nothing.

Bad news. Now, Even though the thing I am changing (“Event”) is properly identified still the action of adding to a list items within it does not happen. I have no error message appear in the log and still nothing is added.
What is the procedure to open a support call?