Issue with Google Maps Addresses Not Loading in Search Box

Is anyone else having an issue with Maps no longer materializing dropdown results in their search boxes?

For months this worked totally fine, but we just noticed it stopped working in the past couple days and we can’t seem to figure it out.

Here is us trying to type into the search box field. Nothing shows up.

We have a billing account setup with Google Console, API keys are all generated properly from what we see, and entered into the bubble backend. Here is our setup of the search box, which worked fine for quite a long time.

In a fit of frustration, we rebuilt the search box the same way, and somehow the results were suddenly appearing. So then we replaced the old search box with the new one, but today the new one isn’t working now. Arggg.

Is there some sort of Maps bug floating around? Did something change in bubble that now we have to do something to not have this happen?

Any help would be appreciated!


When I accepted to allow my app to use my current location, then the search box works. See below.

When I deny it my current location, the search box does not materialize results.

This is strange as it did not used to do that.

Another Update:

When I delete the “default value” which was set to “current geographic position”, everything works fine again.

But I guess I can no longer ask the user their geographic position on page load.


Is there any reason behind this occurring?