Latest round of bubbles consistent bugs that haven't been fixed

I’ve raised several bug tickets over the last month for bugs in the editor that are still unresolved. Is anyone else experiencing these issues or is it just in my accounts? I’ve experienced the issues in multiple bubble apps but the bugs are inconsistent. I’ve recorded detailed looms and sent them to bubble support for each bug but nothing seems to get fixed.

  1. search tool is inconsistent - it frequently doesn’t return all the actual results when using the “field used in” or element exists on searches - this is super annoying as I’ll delete something to clean up a database only to find that it actually did exist in 20 places that weren’t reported in the search tool… even though some places got listed (not all).
  2. reuseable elements cannot be searched and added from elements tree - this one has been on and off, it seems that the reuseable elements occassionally cannot be searched and added to pages no matter what I try. the only thing that seems to work is waiting about 10 minutes for bubble to finish loading I guess. I just get a coffee and come back and it seems to be resolved.
  3. editor still crashing on page memory issues - I was resolving this with hard resets but the hard resets seem to be needed more and more frequently now - more like every hour instead of every 4 hours. The issue seems to be most apparent when I’m editing multiple pages or using search tool multiple times - I’m assuming the editor is trying to cache all this data and isn’t clearing it… this should be a quick fix (just expire the cache items after 30 mins?)

This post is really aimed at trying to get bubble support to fix these issues since they have been going on for 6+ months now and they keep releasing features - which is great - but the core editor still has incredibly frustrating bugs.

Please fix the bugs first before working on new features. We need a stable editor that is reliable. New features are nice but if the core editor is unstable it’s just incredibly frustrating and undermines all the new bells and whistles you add.

1 Like

Yes, this happens even when you have the location of where the field is used open and on search tool checkbox to restrict to only search this page…definitely an ongoing issue that most people will not notice until they search for a field use that they know 100% is used somewhere and the results from search tool are null.

I’ve seen it but not often and usually I need to refresh browser to get it to work.

Welcome to the party

Shiny new things get our attention, fixing the old bike in the shed is put off as long as possible

I’ve also observed repeated but intermittent search failures. Sometimes, the search box displays an error along the lines of “sorry, but the search didn’t work”. When that occurs, it’s immediately replicable and no amount of retrying or refreshing fixes the issue. I haven’t taken the time to formally report the bug.

Have you tried their new release of the editor? Does it help?

I just encountered the issue again, and formally submitted a bug report this time.

At the time, I was indeed using the newautorun=true parameter. I definitely also observed the issue prior to that being available.

In this instance, the issue was correlated with including text in the “Contains text” input. Once the error occurred, I reliably replicated it by performing different searches that did work and then trying again a search with “Contains text”, which again resulted in the error.

Additional testing:

  • I duplicated the browser tab, tried the same search again, and received no error but the results were inaccurate: all text elements unfiltered by my “Contains text” value.
  • I removed the newautorun=true parameter in the duplicated tab, refreshed the tab, and tried the search again, and then it worked as expected.
  • I re-added the newautorun=true parameter in the duplicated tab, refreshed the tab, and tried the search again, and it continued to work as expected.
  • Back in the original tab, I tried the search again and continued to receive the error.
  • The two tabs exhibited near-identical memory usage: 677 MB vs. 703 MB.

App search tool - no error

App search tool - error

I’m practically giving up submitting bug requests because the support is so terrible.

Normally the only response I get is “we’ve received the request but we had to pass it on to X department… they’ll reach out with an update…” which never happens.

I checked my inbox for the last 11 bug requests I submitted over the last 3 months haven’t received a single “followup” after it was passed up the chain. So is there any point doing a bug report?

As soon as there is an app that does what bubble can do (or even close enough to it!) I’ll jump ship because bubble becomes more and more frustrating to work on every month at this rate.

For istance today I noticed that they removed the “reveal in element tree” from the right click on an element. That’s incredibly frustrating because the element tree rarely jumps correctly on a complex page and I rely on that right click function!

Today I found another bug in that the editor crashes during merging branches. I think the bubble servers must have been having a moment for a few hours today because the bubble editor refused to load for several hours - even after hard resets and computer restarts. Rest of the internet worked fine, it was just bubble servers.

The irony is that I went to the forum to see if someone had reported an issue of the entire bubble editor not loading and just hanging and crashing constantly.

But the bubble forum did the exact same thing!

So my assumption was that bubble was doing server maintenance. It would be nice to know that though. I mean, a simple “server maintenance, we’ll be back at 3pm” redirect would have been amazing. Simple, effective, no frustration. I wouldn’t have had to waste 30 minutes refreshing and trying to debug the bubble editor.

Often enough when this happens if you send a follow up email they will likely bring their attention back to it. I’ve had to do this often enough that I put a folder into my email client just to store all Bubble Bug report threads that have not been resolved. When a resolution comes back, I remove the email chain from the folder, and every couple months will send in follow ups on all that have gone unresolved.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.