Live DB updated but not Dev

What might be the reason why the same flow that updates (changes a field in the user ) in the live DB doesn’t update the Dev database. Privacy settings are the same. The strange thing is that in the UI, for testing, I can display the change with a search on the Dev DB, but when I go into the data and look at the records, it isn’t changed and the next time through the flow it returns to the DB value. It’s acting as if there was a phantom DEV database? Thanks

dev and live database are wholly separate from each other, as are the dev and live version of the apps…what this means, is that what you do in the live app does not affect your dev app or it’s database at all.

Thanks, yes, I understand that. I’m a newbie with Bubble, so please excuse my ignorance. When I run in the development mode, using the dev DB the dev DB item for a user doesn’t change. When I’m running the application (not using bubble but called from another application), using the live DB the DB is update. I’ve experimented a bit more. In the flow that is updating the DB, I noticed that after the update (a thing), I display the think with a search for that thing and it displays the DB has been updated. but when I look at the DB, it is not. Then when I go back to the index page (it’s a one page application), while I didn’t think I ever left it, at the point the update actually occurs … BUT only in the Live DB when running in Live mode, but NOT in the DEV database when running in Dev mode.

Are you using the correct version-test/version-live URL path?

I’m using a domain that is pointing to bubble. Of course in dev mode, I’m just logged into bubble. How would I know if this is the correct version and/or same version?

There seems to be something I don’t understand about what happens when a flow goes back to index (my one page app) from a flow. In the live mode, while a flow changes the DB, it seems the DB isn’t updated until the flow returns to the index. However in Dev mode, even when it returns to index, the DB is not updated. However, if I move the update in the flow when the page is loaded, then the update works in both DEv and Live modes/DB’s. Could this be related to cookies or a timing thing (still struggling with the timing of events and flow items).

Your live application and development version are wholly separate from each other. You are only using you live domain there. Dev domain is

When I was running in the dev mode I was using the dev db.
PROBLEM IS SOLVED: It was the blasted timing thing. I put the code to update the database after a Custom Event and it worked fine. I understand bubble’s desire to kick off tasks before others finished, but this makes things very difficult because step by step will also act differently than run.