Forum Academy Marketplace Showcase Pricing Features

MapBox Plugin Bugs

Hello @ZeroqodeSupport & @vladlarin,

It seems as if two actions of the MapBox Plugin aren’t working:

  1. Remove Marker from a MapBox Map
  2. Add/Remove control from a MapBox Map

Could you please check this and fix, thanks!

Thanks

1 Like

Hello, @berlin_based.

Thanks for reporting, sorry for a delay on response here.
We’ll definitely check this and offer an update asap on the matter.
Thanks for understanding.

Regards,
Zeroqode Team.

@berlin_based Hello.

We pushed an update regarding the issue :

  • Remove Marker from Mapbox Map
  • Add/Remove control from Mapbox Map action has been put on hold and removed from latest version at the moment.

Please upgrade to plugin, refresh the app and give it a try. Thanks for understanding.

Regards,
Zeroqode Team.

Hi there is an issue with this plugin and the markers… clicking on the marker reports back the prevous marker ID, meaning each click is 1 ID behind the clicked ID, and thus pulls of the wrong records.

Hello, @ryan8
Thanks for reaching out.

Firstly, please allow us to ask you for more details on your request. It will help us to investigate your request more carefully.
Also, please provide us a screenshot (or maybe a screencast) of your current settings for the waypoints and let us know the scenario, how exactly you are willing to use them.

Looking to hear you soon.
Best regards,
Zeroqode Support Team

Here is a link showing how the ID is lagging behind the click. You will see it takes 2 clicks to get the current ID from the icons

Also, the add the add icons list does not works since there is no lat long fields exposed like in the demo site you guys have.

Hello, @ryan8
Thanks for the provided details.

Unfortunately, the mentioned issue is a bit confusing due to the absence of details about your current settings.

Seems like the error occurs in the workflow for the “Add a map marker” action. Can you please share with us the mentioned screenshots?

Can you please specify, where exactly you don’t have the Longitude and Latitude parameters: within the database or in the settings for the action?

Looking to hear you soon.
Best regards,

so with the markers, it is missing from the workflow action, BUT it is there on your demo page. All though the demo you have seems to be much further along in dev then this version judging by all the additional actions.

in the zerocode demos site (testing), the lat and long data is exposed below the marker source

this is how i am adding the marker ID. The ID is actually stored in BUBBLE not Airtable just FYI. That is just a fixed ID, so it is NOT using the AIRTABLE API or anything, just a plain old bubble DB text field. Once I click the ICONS though, the ID lags. You have to click it 2 times to get the ID to load and use it to reference a record for the popup.

Hello, @ryan8
Thanks for the screenshots.

Please allow us to mention, that the functional, presented on the Demo Page for this plugin is available for our users. That means that users use the same tools we use (the latest version is required).

Can you please add our Support Team email to the list of collaborators to your application and provide us a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,
Zeroqode Support Team

I am on the current version… you can see that mine and yours are differnet. You have way more actions that i do not. The first one is mine and the second one is yours from the demo


i have added you as a user. the page of interest would be the feed page…

1 Like

Hello, @ryan8
Thanks for adding us as a collaborator to your application.

Unfortunately, despite our attempts, we cannot test your application without credentials:

We suspect that the information is not pulled from the Bubble Database, but is obtained by a third-party plugin. In order to fully check your issue, you can share your credentials to our email ([email protected]).

Looking to hear you soon.
Best regards,
Zeroqode Support Team

sent you the login. made you admin i dunno if that helps

Hello, @ryan8
Thanks for providing the information.

We have analyzed your issue and already fixed it.
As was mentioned earlier, you try to get information from an external source, but not your DataBase. Due to this fact, the plugin simply does not have enough time to receive this information.

For this reason, we have added the pause before actions and all is working properly.

Also, allow us to recommend you to use another image ( or just save it from another resource) because his one reproduces an error due to the Cors Politics:
image

Hope our support was helpful for you.
Best regards,
Zeroqode Support Team

oh okay cool… what about the missing actions. I am missing a lot of things that are in that DEMO

As you can see above there are a ton of action’s, and events that i do not have. Also i can not add a list of markers cause the LAT LONG field in the action is missing

Hello, @ryan8
Thank you for the question.

Please allow us to mention that fixing the issues within the user’s application is beyond the scope of our support team’s responsibilities, unfortunately :pray:
We can access the user’s application as an exception when the cause of the error cannot be found out.
So, you need to fill in all missing information by yourself using our Demo Page as an example of correct settings.

Please find the screenshots from our page with the settings for the “Add a list of markers” action:



You can simply add the Longitude and Latitude in the workflow for this action.

Try these settings for required action and let us know about the result.
Best regards,
Zeroqode Support Team

I think you are misunderstanding… the plugin DOES NOT have the actions or events shown in the demo. They are missing. Please look at the screen shots again. There is no upgrade option. It says it IS the current version. The LAT LONG boxes are missing in this version of the app, and i can not get it to pull the advertised features that are clearly on the demo site. I have tried to uninstall it and reinstall and it does not bring up the new actions and events that are just missing.

It appears that EITHER the demo is not published to the bubble plugin store correctly OR mine is stuck on an old version with no option to update to the one on the demo site.

UPDATE: I tried installing it to a new app, and same problem. Loads an old version with NO option to upgrade

MINE

YOUR DEMO SITE

As you can they boxers for lat and long are missing

Hello, @ryan8
Thanks for your detailed clarification.

Indeed, you can see on our Demo Page more features than in your application.
It happens due to the “Testing mode” on our Demo page:

Please note, all options that are not visible within your application are just not deployed yet. They will appear soon in the new plugin’s version. We will update you once they will be deployed. :pray:

After some tests, we have added the Longitude and Latitude into your database ( with the correct title and data type) and it appeared:


Allow us to recommend you to use exactly these values for the “Add a list of markers” action.

Best regards,
Zeroqode Support Team