Forum Academy Marketplace Showcase Pricing Features

Marketplace app can not save address

hi, I’m in the mid of modifying and customising a marketplace template.

There are two places which require the buyer user to fill in the address, i.e. 1) in her profile, and 2) in the check out page. However, neither page can save the address info and both have the same popup error message:

The template developer doubt it might be bubble’s system error, but the same issue has persist for several months.

Can someone help?

Might be something with the way it was built…perhaps this is a built in error alert if the data values are empty…Could be privacy rules.

Have you reached out to the developer to find out what is the cause? They should be able to help you right away with what the problem is.

I think it’s because you have a custom domain on the app without valid google API keys to handle geographic addresses. You should notice this if you enable the debugger.

1 Like

Raised to Zeroqode a few times already with obscure answer, like they didn’t have such problem in their original template. Quite disappointed with their after sales service.

They don’t have this problem indeed because it’s related to something on your app. I recommend you again to look into this using the debugger and check your API keys for Google API.

hi
I’ve checked my Google API setting, it is all set according to the bubble tutorial ( https://bubble.io/video-course/how-to-setup-google-api-keys-1612384311603x783404397562167300)

I’ve also used the debugger:

I have reported this bug to Bubble and wait for their reply. Still get stuck here a big time.

Have you checked your Google Console for errors?

Bubble asked me to check if I add “*” in my API Keys setting, but I have done that already:

Anywhere else that could go wrong?

Do you have your payment details logged inside your Google Billing account? If that is missing, your api will not work. Happened to me once…

Follow this checklist and if it still doesn’t work then remove your keys and create new ones.

  • Add your billing details to the Google Developer Console
  • Remove any restrictions from the API during testing
  • Fill in your API keys
  • Make sure you have the right URL’s set inside your Google Console, also include any potential parameters like ?debug_mode=true during testing.
  • Enable the correct scopes on the Google Console
  • Check if there are no errors using the debugger to inspect the page on errors
  • Remove your keys and try again if this doesn’t work and repeat the process above
  • Start adding HTTP restrictions to your API

Many thanks for the detailed advice!
The bug is finally detected – a typo in my website restrictions. What a lesson learned!

1 Like

No worries, have fun building!

This topic was automatically closed after 14 days. New replies are no longer allowed.