Forum Academy Marketplace Showcase Pricing Features

Mixpanel Plugin not sending any data - test environment

Hey good people,

I’m trying to get Bubble’s mixpanel plugin working in my test environment but my workflows do not seem to be sending any data.

Mixpanel says it can successfully receive my data when I test the connection, so I’m unsure why nothing is being recorded.

Any help would be much appreciated!

Good day,

Please make sure you have entered key under a dev field on the plugin page.

Check the browser console output when click the button which is triggered a Mixpanel event.

Regards,
Oleksiy

Hi Oleksiy,

Thanks for the quick reply.

Keys are in the dev field and nothing bad going on in the console when the event is triggered as far as I can tell. What should I be looking out for?

Thanks,
Zack

Oh, okay. I had a same issue with a Mixpanel. The solution was to create a new project and replace the existing key on the plugin page. Then Mixpanel immediately start capturing new data.

I will try this. Thank you!

Hey @oleksiy, I tried to create a new project but that didn’t work. I also tried to implement Mixpanel without the bubble plugin, just using javascript. That didn’t work either, so I’m at a total loss!

UPDATE: I solved this by unchecking EU data residency for my project. So simple. So painful :face_with_head_bandage:

1 Like

Hello Zack,

Sorry for a late reply, was a busy day.

Yes, I’m about to recommend you to check if this option is enabled as it’s not working when EU data is enabled for your project. I will create a bug report with a Mixpanel support.

Just for anyone who is experiencing the same issue, here is the screen where you have to tick this options off, while setting up your project in Mixpanel.

1 Like

Oh my god, I lost two afternoon trying to figure that out.
Thank you.

I have forked the Copilot Mixpanel Plugin and implemented it to work for EU. Anyone interested can ping me and I’ll share with them. Maybe @copilot or @Bubble can update their plugins to give an option for EU servers.

Hello,

It would be helpful if you can share this information here, incase someone runs into the same issue.

Thanks

Use this instead on your Header when setting up for EU

Change mixpanel.init to this below

mixpanel.init("Your Token”, {“api_host”: “https://api-eu.mixpanel.com”, batch_requests: true})

Hey @koechamos51,

We won’t be able to add dynamic locale support without introducing an element or manual initialization. If we implemented your resolution involving a modified, shared HTML header, we’d force all plugin users to the EU locale which isn’t preferable. As an alternative, we’ll explore introducing a dynamic library initialization call in a future update. :slight_smile:

2 Likes

Hi all,

I’ve followed Bubble’s Mixpanel plugin documentation and this forum thread but Mixpanel is still not receiving any data. I wonder what I did wrong, screenshots attached.

  1. I entered Token and API keys under the dev fields on Bubble’s Mixpanel plugin
  2. I setup a simple workflow: send an event to Mixpanel when a button is clicked
  3. I disabled European Union Data Residency

Is there anything more that needs to be done on the Mixpanel side?

Also, when I view page source I don’t see Mixpanel added to HTML header of my page. Does this mean I didn’t set up Mixpanel correctly?

Thanks for your help!
Alvin

Hi there,

Also having this problem - did you find the solution?

I’m having the same issue - haven’t been able to figure out a solution myself, unfortunately, and I’ve followed all the steps in this thread so far.

@haryanto.alvin @emma2 - were you able to figure out a solution?

Hi all - I had this same error (zero event data propagating to Mixpanel, despite, seemingly, correct implementation on my side) and thought I’d save others the many hours I spent figuring out the cause of the problem.

In my case, the solution was simply to access the bubble app via different browser. I was using one with ad/tracker blockers, so turning them off or using another browser without these features solved the problem.

Hope that helps any others with the same problem.