New Stripe Connected Account always has my email for name

I’m using the Bubble Stripe Plugin and I’m trying to Register businesses for my Marketplace App. This appears to have worked in the past but less so now…

I’m still only using Test Data in Stripe so maybe that’s it but it’s surprising if it is.

It works in that when a user hits a “Register as a seller” button in my app, the workflow runs and it takes them to Stripe where they fill in a form to create a Connected Stripe Account. However, when I check this in my Stripe dashboard and look under “Connect”, all the accounts that have been created have the same account name which is my email address rather than their business name which would make a lot more sense. They do all have different account IDs so I can see they’re different entities but it just doesn’t make life very easy with them all looking identical.
I had a Chat with someone at Stripe today and they said I could edit it manually within Stripe but this option isn’t available with “Test Data” and I don’t want to edit these things manually anyway as it will be a pain in the hole.
Can anyone tell me what I need to do to ensure that my Connected Account Names show business name when I create them?

Here’s a screenshot of what I mean…all Account Names are my email address although one of them clearly worked a few months ago…

Id check your workflows that trigger the connected account creation to ensure you dont have a text field that has your email in there from testing.

This happens to me too. It is a Stripe thing, not specific to the plugin, but Stripe generally. When creating a test account, you are actually creating a test account, so to make it so that it doesn’t show your email, just add a name to the test account during the Stripe account creation.

Thank you. I checked my workflow and all seems good.