Newly created apps not loading SSL version, has something changed?

After creating two new apps, I can not get the SSL versions to load for both of them. Meaning, when someone goes to the http:// version the page loads fine but when attempting to access https:// the page does not load

This site can’t be reached

[app_url] unexpectedly closed the connection.
Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

I checked the SSL box (after completing domain setup and SendGrid setup) as I have over 20 times before, but this time, even after waiting over 12 hours, the app does not auto-redirect from http -> https and I never received a verification email to my admin@ email in order to confirm SSL.

Is this a bug? Why am I not receiving SSL verification emails anymore? Has something changed on Bubble’s end that is automating this verification process? If so, I believe it has broken for me permanently. I just tried to launch the same two apps again, re-setup the domains, verified DNS records are correct, and after checking the SSL box nothing happens. No email, and 12 hours later unable to load the https version. I have submitted bug reports for both apps.

@emmanuel Please advise? I’m having this exact same issue

Anyone else? One of the two apps I mention will now load SSL briefly, flashing an error about a poor/incorrect cipher. After a while the page reloads and this happens all over again. I can confirm after trying to create 6 more apps, SSL does not work on any of them.

We’re looking into this.

1 Like

Hey All,

About the recent issues with SSL – we use a service called Let’s Encrypt to provide certificates for app domains, which comes with a rate limit of 20 new certificates per domain, per week, including sub-domains (e.g. would be a sub-domain of Check out this link for more information about the rate limit policies of Let’s Encrypt.

Our logs indicate that this rate limit has been hit for certain users’ apps that have a large number of sub-domains. The limit uses a 7-day sliding window, so we’ll reach out individually regarding when your SSL will reset. Sorry for the confusion.


Thank you for the information. I have not issued over 20 certificates even in the last month, is there any way to look up my current allowance limits on Let’s Encrypt? I’m still not seeing SSL appear on the new apps. Is it possible by clicking the SSL checkbox repeatedly on one app that I am running out of my weekly limit?

I think one feature we need is a visualization of the SSL being registered since after checking the box I have no idea what’s going on in the backend.

Hi Phillip, what’s the domain name of your app? You can search on The ‘not before’ field tells you when the certificate was ordered. If you’re having a problem with SSL that is not related to this, we’d certainly like to know.

Yes, I think it’s possible. I’ve had Let’s Encrypt certs through a hosting provider, and after a certain number of attempts to renew a cert, I had to wait a week to try again.

My issue is that my app fails to redirect requests for the http to https.

In other words, works as it is supposed to, but there is no redirect from http to https. I just get a dns error page when I navigate to

Sometimes it takes an hour or two. Try it again and let us know?

Oh, and regarding your question about whether clicking the SSL checkbox may be potentially exhausting your cert limit – not likely. We order an SSL cert for a domain only when it is visited by a user, after checking if we have a valid one in our caches.

It’s been several days at this point. I turned on the SSL option this past Friday

Hey – just checked the logs, and they say only one certificate has been ordered for your domain since August 1st, so you aren’t maxing out any rate limit on the Let’s Encrypt side. As well, we tried reproducing the issue again and the domain reroutes to https just fine for us. Can you send some more details about what’s going on? Perhaps a screenshot?

I tried upgrading from Personal to Professional, and then it started working

This topic was automatically closed after 14 days. New replies are no longer allowed.