Outbound Email Sends - A few questions

Quick overview- I’m in the process of tweaking an email sending tool. Users can email my b2b contacts with marketing emails.

So far so good, just a few issues:

I’ve created an api endpoint, that selects the right list of emails (based off the users custom selection) and emails them all, (great!) BUT with sendgrid, you need to have a valid “TO:” field… and these lists are all in the BCC field, as I don’t want the consumer to know its send to 100 other people, lol…

Ideas here on how to get around it?

Or should I be constructing this in a different way, maybe? So the emails send individually, as opposed to all at once? I’m putting a delay of 15 seconds on sendgrids side, so I’m not too worried… just don’t know how to get around the TO: field showing up there.

Hi @andrew6 - would putting something like "admin@yourdomain.com" in the “To:” field work for you?

1 Like

@nikolai - that is a temporary solution to continue the MVP - BUT the data(the people receiving the email) will know that the email came from a marketing platform…and probably not be as effective…

You know what I mean?

Is there a way to send to these email addresses individually? like so they are the “to field” … does that make sense? for example its a list of 100 people, but each “user” of the application will have their own 100 contacts they are emailing every week.

My current setup is to just adding the 100 in a list, and sending the list in the BCC field.

Thoughts?

@andrew6 - is this a different scenario than this:

@nikolai - Yes, mostly. That post got me to where I am now. At that stage, I couldn’t schedule the emails & send them.

Now the emails are being scheduled, and I can get them to send, just not without a “To” field…

SO to answer your question, its the same application I’m working on, but a different issue, so to speak.

I can show the app and maybe that would clarify the issue>?

Hi @andrew6 - just so I have it straight in my head, you have N-number of Users who each have a list of (at least) 100 email addresses. And you want each of your Users to send their respective list of 100+ email addresses an email. But for each of those hundreds of emails being sent, you don’t want those email addresses to be in the “To:” field, but rather BCC’d, is that correct? Or do you want each of those 100’s of emails being sent to have one unique email address in the “To:” field. Thanks for clarifying (bit of a head cold last few days).

1 Like

@andrew6 - I did a quick mockup. The data structure is as follows. Under Data Type User I have a Data Field called “ListOfUsers” which is a list of type User. Each of the app’s Users would have this data field filled with 100(s) of email addresses. Then in the workflow below, do the scheduled API flow. Do you have something similarly setup in your app?

Then the API endpoint is below. I had two Users each with a list of two end-users. When i ran this, I got 4 emails, one to each to the end-users. Hope this helps.

NOTE: In my data structure, I had “ListOfUsers” setup as Users - I think you want it set up as “text” since I think you’re just capturing emails and not actually setting up 100’s of Users in your app.
image

@nikolai - sorry the late reply, I was away for the last hour. I appreciate you taking time to clarify.

You have everything correct in your understanding of the application, I want them to all be in the BCC with NO “TO” field, as if there is no “TO” field, they won’t know they are BCC’d. To further explain, I wouldn’t mind if they were all one unique value in the “TO” field, I would just like them to not all be sent at once, so they can not realize that others are being sent the same email…

I hope that helps?

@nikolai - I’m replying to your most recent post, with the data structure…

I tried it this way, BUT I was running into a few problems, (I probably set something up incorrectly). When I ran a workflow on a list of users, it would send each user an email, 100 times over… SO it rant the function 1 time, per user receiving an email.

Also, you are correct, I don’t have 100’s of users using the app…just 100’s of emails, for example… so the type would be text.

Can you clarify, how to get the workflow you set up above, not to send out 1 email to all the users x the amount of users? Can I post something to help explain my issue.?

HI @andrew6 - If you’re ok with it, it would be easier to see your data structure, workflow and API endpoint. You can take screen shots or DM me with link - whichever you prefer. Thanks!

@nikolai thanks for taking time to look at this. The two models I’ve tried are pictured below. The goal, is to just send individual messages to these contacts, 1 after another… (like 15 seconds out)… , but that is not how it is working.

Current setup - (which requires something to be in the “TO” field, or it won’t send: This causes all emails in the list to be sent as BCC, at the same time. Not idea, but serviceable.


Other option Works, but it just sends all the emails to the to field, at the same time, and everyone can see everyone else in the list.


Goal to send to the list, as the “to” field, individual emails.

The bottom option (“Other option”) is the one you want to work with because it’s handling a List of things which is appropriate for your list of emails. Bubble will iterate on the list so if there’s 100 emails, it’ll call the API endpoint 100 times.

Referring to pic below, it appears that for “sendinglist” you’re actually sending a list? But with this scheduled API workflow, you want to send the endpoint a single “text” item. So you probably want to replace “sendinglist” with something like “email” and where it shows “Parent group’s campaign’s audience…” you’ll have result from the “List to run on” which will be of type text and the value will be an email address.

image

In the API endpoint, a few things: 1) Click the “Optional” button for “sendlist” key. This will allow the workflow to pass info the the API endpoint but not require it (leaving it blank and not sending data from the workflow will cause an error). I’m saying this because I don’t think you’ll need “sendlist” but don’t want you to delete it in case it is needed.
2) Add another Key such as “email” . It’ll be the same type sent from the Workflow (probably also “email”)
3) In the API endpoint workflow, put “email” in the “To” field.

Pretty tough doing this via email and not seeing your data structure but hopefully this makes sense and gets you a little closer to figuring it out.

image

1 Like

@nikolai hank you so much. This helps a ton. I think this will get me on the right track…

@nikolai - I actually am having a bit more problems here. I think you’re pretty knowledgeable about the issue…I’m unsure if you freelance… but I’d be thrilled if you could spend 10-15 minutes looking at the data structure… something is just not clicking in place with this.

the most recent solution worked… BUT it’s still sending all at once, and they are all CC’d to eachother…

If something works for you, please do let me know!