PDF Conjurer (updated free plugin, now saving to database)

Thank you for your response @lancegerarrd . When I try finding ‘Start a PDF Model’, it doesn’t appear in my list of actions

I suspect you have not yet put the PDF model element on your app page.


@lancegerarrd That was the issue! Cannot thank you enough for your help. :raised_hands:

ur welcome!

Hi @vini_brito . What’s the maximum number of workflows I can do. I’m doing a really complicated Pdf and after running 46 workflows it’s not running the rest. I can see that in the debugger.

Workflows or workflow actions? Also, do you see any error in the browser console? Take a look around the web if you do not know yet how to look into the browser console.

Nonetheless, maybe you will have to move some things to the backend.

Hello fellow bubblers!

Today I released a fix to the “Parse BBCode” instability issue and a new feature:

The ability to display a total page counter on the footer alongside the current page counter and also customize its divider :blush:

Take a look:


Upgrade your plugin versions, refresh your editors and enjoy! :grinning_face_with_smiling_eyes:

This is especially useful for legal stuff like contracts :wink:


Hi @vini_brito

The plugin is wonderfully working on my app. However, I just noticed that some words are not printed on my pdf. When I insert other words in the same place, there are no issues. Is this a known error?

Kind regards,

I never sponsored anything in my life, but I would be happy to sponsor this project if it ever comes to reality

Ah, there are a few paid alternatives out there, like “screenshot element” or something like that.
Searching for both of these keywords will definitely bring them to you :wink:

1 Like

Never heard of that, try checking if you are using a font that does not supports said words/characters, if not, then please file a bug report here: Unlimited Bubbling - Report a bug :blush:

Hi guys,

Great plugin. Does anyone have an example with workflows incorporating a header? I am getting errors on conjuring the PDF when i try and add a header in.

I am getting an error when using the element action Add column to repeated table a PDF model. My current setup is Start PDFModel A ->…Start Repeating Structure ->Start Repeated table → Add column to repeated table ->End Repeated Table → End Repeating Structure ->…Conjure. The table name and repeating structure names all match. Error message below.

Also, I made sure the list is not null.
BTW, amazing plugin!!

Thanks in advance!

@californiaprivacypol Hello hello! You can post more details (which error shows up and how is your header action setup) and maybe someone can chime in an help. Also, if you want individual attention to get this and more stuff up and running, you can get a paid session with an expert for you, just send me a private message for it.

@ccooper Same thing as above! Also, your setup seems right, and it is great that you mentioned that the names match and the value is not null, because these are usually the main reasons.
Try using the safest name possible, lower case, no spaces etc. Something like “pasta” without quotes and see if the problem is there.
Also check the “number of iterations” in the “Start repeating structure” action.

I have the exact same error, @ccooper.

New to the plugin, so I assume it has something to do with having to wrap my head around where this action draws it’s data from.

I have a thing that is a list of invoice lines and am trying to get the data from there. I wonder if I’m doing it wrong :slight_smile:

Hi @vini_brito

I encountered an issue with the Pdf conjurer. I’m currently using it for over a year and all of a sudden, it doesn’t work anymore in both my live & development version of the app… This means my app has become quite useless at the moment…
The workflows run, however no pdf is generated, while before I encountered the issue, I’ve never had this. Also no error message (white popup’s) are shown. Can you please help/advise?

Kind regards,

@vini_brito I just wanted to add my vote to the list of people experiencing an issue when trying to use the “Add column to repeated table” event. I have used PDF Conjurer successfully for about a year in one part of my app (without repeated tables) and am now working on another section which needs repeating tables. I spent a few hours today trying to debug the issue but I can’t see anything wrong with my code/setup and based on the recent issues reported by others I wonder if there is an issue with the plugin code? Could you kindly investigate on your end?

Like others, the error I’m seeing in my testing is as follows:

The plugin PDF Conjurer / action Add column to repeated table a PDF Model threw the following error: TypeError: storedCurrentListThing.length is not a function

@vini_brito I am probably missing something obvious, but is there a way to apply a custom font style to the page numbers in the footer?

Hi Vini,

Apparently there was an issue with an image! Upon reupload of the dynamic image, the problem was solved :slight_smile:

Kind regards,

1 Like

Hi @vini_brito - quick question. I’ve got a repeating table that goes through each Room on a Project and displays a list of jobs and also pictures. I can’t quite seems to get it to not throw an error if there are no pictures for that room (they are optional). Is there a way to get it to handle this as it displays the error but then generates the pdf a moment later. I tried using the “only when” box on bubble but it evaluates to a list so won’t let me,