PDF Conjurer (updated free plugin, now saving to database)

I Kent and Vini. I had the same issue

Hello everyone!
I’d like to display header and footer in a PDF created by Backend Workflow, but they don’t appear.
Of course I have run [Active header/footer] in Workflow and checked “Is this element being put into the header/footer?” in the elements I want to insert into the header/footer. Where is wrong?

When I don’t check “Is this element being put into the header/footer?”, it shows up as normal text in the PDF.

Thank you in advance.


I get an error while trying to write text (within multicolumn paragraphs):

The plugin PDF Conjurer / action Create text on a PDF Model threw the following error: TypeError: Cannot read properties of undefined (reading 'columns')
at eval (PLUGIN_1543086664409x454646894723334140/PDF-Conjurer-element_action--PDF-Model-Create-text-on-.js:719:76)
at https://dhtiece9044ep.cloudfront.net/package/run_debug_js/7e6d3e1b36edba243a873a06888e769449b3d0078b038abedacdf69e50ec10eb/xfalse/x15:6:2251760

What does this means?

OK, found out what was wrong:

I checked “use for Multi Column” on my text’s but forgot to fill out the mc-name…

1 Like

Hi, I’ve got a question regarding tables and custom tables.

In my “normal” table, using Create table on pdf model I can specify body and header (font) styles. This is working correctly.

Im doing the style naming with option sets, so I don’t need to worry about spelling errors.

Now, in my Start advanced table pdf model it seems like the styles do get ignored. The rendered PDFs have standard text and don’t change in body and header.

I’ll append the settings of the “standard” table and the advanved columns below.

Any ideas? I want to use the advanved tables for fixing the width of each column.

Screenshot 2022-02-17 at 14.39.13
Screenshot 2022-02-17 at 14.39.37

The plugin stopped working on my Chrome Version 98.0.4758.109 (Official Build) (x86_64). The plugin version is 3.3.2 in production and 3.7.0 in dev. It was working just fine a few days ago. Did anyone else experience this issue? I tried reuploading the image, as above, but it still doesn’t work

I figured out what was happening – the workflow I was using was activating sections in bulk and then adding text/images to them afterwards. What fixed the issue for me was pairing Activate with Create actions, for each of the sections of the PDF I was generating. This solved the “nothing happens at Conjure” issue

1 Like


Is there a way inside header to insert new text in the next line? Every new text goes to the same line.

Thank you

Hello everyone!

I have just created a debug logging mechanism, right now exclusively for the client-side version, which is the one that uses “PDF Model X”.

If the workflow reaches the final action without a breaking failure, it will then log what was the end result of the PDF in an internal format.

It logs it to the browser console and also outputs it for you to store the log in your database and also see it on screen.

Helpful for intermittent issues, this way you can automatically log all attempts to create the PDFs and when a failed one happens, get the debug log content about it from your database.
A recommendation is to use an online text difference checker to compare the log of a failed attempt with the log of a successful attempt, this way you will have insights about missing data, different data and others.

Also helpful for me to assist you.

More instructions:

1 Like

Hello @vini_brito ,

So far I’ve enjoyed your plugin a lot and I’ve been able to build a robust PDF just following all the thread discussions across multiple topics. But at the moment, I’ve been facing a particular issue I’ve not been able to overcome. Let me describe what I’ve trying to do.

I have a PDF model (client side) and I’ve setup multiple texts. So far so good.
Then I’m trying to create a bundle of elements (multi-column sections, texts, etc.) multiple times depending on the size of a list. Here is where I come across a problem.

Trying to solve this client side using (home made) iterators, I get a bubble error stating I cannot make circular calls of workflows either directly or indirectly, so I tried the back-end workflow approach.

In this approach I’ve setup the PDF Initialization and created several texts successfully, but then I come across the same problem, trying to call another API workflow on a list is a nightmare. I do not find a way to pass my progress as an argument to the API workflow so I do not lose what I have so far.

So, summarizing what I’m trying to do, is I need to be able either to pass the PDFModel with everything I’ve setup con client side to the server to be able to iterate through the list of elements and create my bundle of elements to finish my document, or to be able to do the same but all of the time being on server-side.

Do you think this is a feature that already exists but I’ve not been able to find? Or is it something so complex that is not in the scope of the plugin at the moment?

P.D. Great work with the plugin/support so far!

------ EDIT ------
Found the solution using another one of your plugins: " SimpleLooper". If anyone needs help implementing the solution I suggest do not hesitate to comment here or contact me.

1 Like

Hey hey @vini_brito hope you’re well !

I asked myself if you have a trick for backend pdf conjurer, on add image action, if image is empty ? because if I add there some dynamic value, and this value (image url) is empty, it crashes :confused:

I used to handle that on front with “if xxx image is not empty” but with the "previous step " thing it is not so easy to handle in backend!

thanks :slight_smile:


I love this plugin … but can’t get it to meet my use case. Maybe I don’t understand what I’m doing, or maybe I’m getting beyond it’s capability. I have a repeating group:

and a structure of Flight which has a linked invoice (only one) but the invoice has linked items (normally 2 but can be more). So it’s sort of a table within a table. I can conjure a PDF for the first 9 columns - that’s great. But I can’t work out if / how I can structure it to add the next three columns so the result looks like the screenshot.

btw I am doing this because the table gets big and I want to print it in pages … PDF Conjurer looks like it will do this but maybe I should be using another plugin!! - I have Print Pro but I couldn’t get that to do nice pages …

Many thanks, hoping someone can help.


Hi @vini_brito
hi plugin users,

I am using this plugin for quite some time now and overall happy with it.

I just experienced that if a data fields content exceeds the final pdfs page height than the particular data set is not displayed in the final pdf output.

I did research on it but couldn’t find a solution.
This is giving me big headaches.

Appreciate every kind of support!

Have a solution for this:

if some text or image miss, the plugin will crash and you’ll not have pdf.

To resolve this, use :

For an image, in the “dynamic image” field put this :

For yes, the url of the image you want to display
For no, thr url of an image (same size) fully white (or maybe a transparent png if you use a background, but didn’t try this)

For text :

add an empty space in the “formatting for no” field if you want nothing to display there and the plugin not going throw error.


@vini_brito : some words to edit there:

1 Like

Ooh thanks for letting me know! I can’t believe I never noticed these words and that nobody told me about them earlier on :sweat_smile:

Also, thanks for sharing the image technique above!

1 Like

is it possible to create a template and just fill it with data from database ?

Hi bubblers!

Can anyone point me in the right direction with using different fonts in conjurer? There are two elements, Load font to PDF and Load font to PDFModel. How exactly does one use them? I am a bit puzzled :slight_smile:

Removed message as no longer relevant.

can some guide me on how to load a font to a pdf model?