Plugin Announcement: Rich Text Editor

“Extend to fit” will increase the vertical height of the element as the user types longer text. Is this not working for you? If it seems like a bug, more details (eg a link to your app - can be by DM) would be helpful.

@luke2 - maybe :wink:


Plus +1 to Custom fonts options and default font.
Plus +1 to have more control over what to show on the toolbar options.

I’m running into an issue where the new RTE isn’t responding correcting to parent group’s item changes or reset workflow steps. It almost seems like it requires 2 of each command for it to actually respond.

I have to run two display data workflows for it to work (although it works the first time RIGHT after the page is refreshed) Two workflow runs to clear it etc.

Here’s a screen recording of it -->

I will submit a bug report as well.

Same bug to display data in Rich text from a popup :confused:

I enter a link…


I save the link then i save the data in the data base.
and I show the link in a text zone…


Note the 3 slashes ??? and the tags around the link…

+1 on this. The most common request i get! If it’s not possible, bullets / numbered list / image should be in the basic category.


I think there is a bug when using this to autobind in a floating group. The contents of the field do not display when the page and floating group are loaded.

1 Like

This plugin is DEAD IN THE WATER. Just installed it and it will not render and will not let me enter an input. Just get a blank screen with no features. Anyone else having the same issue?

Sorry you’re having trouble with it - we haven’t heard of this particular bug yet. Could you either DM me this app’s ID, or file a bug report (eg by emailing with some info to help us track this down?

After seeing the same thing on the Trixedit element, I think the issue is that it is placed on a popup element inside of a reusable element. When that element is reused on a normal page, the editor does not engage.

Could you validate for me that this scenario works for you? Trixeditor did exactly the same thing so I simply tried throwing it onto a plain page and it seemed to work.

@sanastasi @allenyang I ran into this exact scenario with a pop up inside a reusable group. I submitted a video of the issue to support but was able to work around it by placing a 1x1 sized RTE dummy element on the main page.

1 Like

@sam8, @allenyang Are you guys using Quill to implement this Text Editor? If so, then I’m wondering if you would consider adding Templating functionality to it, since Quill does support templating. Here’s just one use case - to allow my customers the control to customize the order confirmation emails they send to their customers without giving them access to my Bubble App Editor… So they could write something like:

Dear {Users First Name},
We are excited that you have applied to {Business Name}

This would open a lot of possibilities: Invoice/Receipt generation, Email templates, Invitations and more that an end user can customize. It would enable the creation of applications like Hubspot:


Very clever @eli I will try that out. Yet another work around :slight_smile: but hopefully it makes it usable.

Three requests:

  1. Templating functionality as mentioned above

  2. Support a `This RichTextField’s Input is Hovered" condition in the conditional formatting (Regular Text inputs allow this)… so we can change the background color on hover, for example.

  3. There may be a circular reference bug… I’m seeing it when I use the `This RichTextField’s Input is Focused" condition:

All in all, though, this is a very nice plugin! :slight_smile:

Guys! Guys! This text editor is based on Quill:

So @TeamBubbleEngineersWhoAreAwesome when can we expect the yellow gift-box :gift: of templating? :slight_smile:


Seems to be an issue when adding refilled data to the text editor.

If you choose to add in “initial content” and then use the rich text editor to format that initial content it shows the whole BBCode and not the formatted text. In both the editor view and user front end view.

See attached.

Error showing when in Bubble editor view:

Rich text input is not displaying data in popup! Empty nothing. All other fields types fine except the RichText.

Also got this error.

The plugin Rich Text Editor Edit Mode / action Reset a Rich Text Input threw the following error: anonymous
L@ (please report this to the plugin author)

Anyone having issues with displaying text in the RichText editor when loading data in a popup after you display the data in the popup group try adding the action to “Reset the rich text input” at the end of the workflow, it should then display the text. If you see the above error it appears to occur when you reset the Richtext editor before you pass the data to the popup group.

FYI, I reported the same circular reference issue - although unrelated to the RTE - on Feb 2. I managed to distill it down to a very simple reproducible generic test case, and Bubble was able to replicate the issue (bug #8580).

Unfortunately, however, I’ve yet to receive a status update. It’s a real shame there’s a not a better issue tracking system in place. :frowning_face:

1 Like

Thanks @sudsy saves me logging the bug, but yes agree needs better tracking transparency.