[plugin] SaasAlias: Multiple domains and subdomains for bubble apps

Yes I get the same.

Please follow the steps listed under problems in the post. I cant respond to dm with very little info.

Hi! with this plugin,

Can i set automatically - myclient1.domain.com ?

and then, let my client connect your own domain: myclient1.com ?

1 Like

yes that is possible

Hi @gaimed, if these are in beta price until May, why are they already showing at full price ($50 and $25/month respectively) on April 4th?

One other question: I believe it is possible to add an unlimited number of subdomains with your plugins, provided that one uses a separate config for each one; is that correct?

In other words, the limitation of 99 subdomains you are referring to below only pertains to an individual config?

If you dont mind waiting 10-15 seconds then add subdomains to the same config (using action add domain). Add maximum of 99 subdomains per config.

yes and yes


Do you have any apps with SaasAlias already working?
I’m trying to find out if this works as a redirect or if it masks the destination URL.

If I access, for example, client1.mydomain.com, it would redirect to www.mydomain/client/123, right?
So, the URL that will show in my browser will be client1.mydomain.com, or www.mydomain.com/client/123?

If it shows client1.mydomain.com, can I work with navigation in my app, or it should be a Single Page Application?

Will Google index client1.mydomain.com results, or only www.mydomain.com/client/123?



You have two options:

If you use redirect clients will see client1.mydomain.com/client/123

You can also use the saasalias element. It has two porperties. It gives you back the subdomain. You can use that subdomain to get the relevant client and clients will only see client1.mydomain.com.

1 Like

Hey @gaimed,

Thanks for answering.

Do you have any apps with SaasAlias already working, so we can check how it works?


Yes we have apps working. We dont provide access to them to check them out.

:question: :question: :question: :question: :question:

The current prizes wont go down.


I’m a bit stuck while testing the plugin…
My app is already mapped with my own custom domain.

The plugin setup has been done according to the documentation, I also tested using my own netlify Api key, but same result : an error "
SaasAlias: Create Failed with errors: undefined" when I try to create / deploy a subdomain.

Note : the (Google domains) dns setup has been done and is working, the wildcard * is correctly mapped to the ip address (and ping requests demonstrate it’s OK).

I bought the SSL plugin but didn’t notice it implies a domain migration to Cloudflare, what is not possible as my domain is linked to Google Workplace. Any other way to proceed without migrating the domain? Else I bought the plugin for nothing…

You dont need the SSL plugin unless you want to do instant whitelabeling. Try it without. Currently instant whitelabeling only works with cloudflare. It was difficult enough to get that working. So I dont plan to support others. You can also use cloudflare and link it to google workplace.

Did you check the log and error?

Hey @gaimed, in case we already set a domain for our bubble app, do we need to set this domain name in the “bubble app” name field of the plugin settings or do we need to set the bubble app name (without bubbleapps.io). I tried both, the domain name and the Bubble app name, but it resulted in the same error message.

And with my own Netifly key or with the field empty in the plugin settings, I always get the error message, when I just try a simple workflow : create and deploy (deploy is based on the output config of the create action). I guess I’ve missed a step somewhere but I don’t know where…

Can you please look at the manual. It has a description on what you need to set there. Its the ID in the url when editing.

Not an issue for instant SSL, I think 10 to 15 seconds won’t be an issue. I’ll try to get it working with Google Workplace (and Stripe and other third party Api later).

Yep sure, that’s what I did, but I also got an issue… Maybe I can send your the app name in a private message, if you have access to some plug-ins logs?

If you need support follow the steps under problems?