Forum Academy Marketplace Showcase Pricing Features

[PLUGIN] - VideoJS Advanced + YouTube, Vimeo, Wistia, HLS, DASH, MUX, Pre-roll Ads (plus more)

Yes I am

Ok, try throwing in the Execute method action right before you set whatever it is that changes your parent group’s text like this…

image

Set the Method name to reset() and see if that makes it change sources.
Unfortunately, although Vimeo’s own player option is there, it will cause some issues with videoJS but hopefully this workaround will make it play another video.

I’m planning to push a few minor updates at some point soon so when I do, I’ll make it so that you don’t have to use the execute method to make it load new videos. Let me know if it works though! I did run a test and made it work on my end.

1 Like

That worked perfectly!! Thank you so much!! Are the issues you mentioned surround Vimeo major?

(I am playing on allowing users to add videos to their account by 3 methods: 1. Upload to Bubble, 2. input YT link, 3. input Vimeo link. I will use a workflow to change the player type accordingly to what link is being used… Is there a smarter way to allow users to add videos to their profile regardless of source? A way where I don’t need to use Vimeo?) *My users will all have different sources for their videos.

Unfortunately they are.

The Vimeo player will work with videoJS but because it’s Vimeo’s own player being used (and not the VideoJS player) when you have that option set to Yes, not all the mappings (or functionality within other actions) will work. It’s partly because of the Vimeo API which is built into their player breaking it but I only added it for situations where you have a need to set things within your Vimeo account which need to take effect on the videos. For example, privacy settings or subtitles. When utilising any of those video options, you have to use Vimeo’s own player to see/apply them (if that makes sense).

If you don’t have to use the Vimeo player then I recommend you keep that option set to No and allow the videoJS player to play the Vimeo videos instead. Read the doc part I’ve added to the option.

Use formats like this:

and they should play just fine. Personally I’m not a fan of Vimeo, although they’re great at what they do etc, if you’re using Vimeo just to host videos, Wasabi is super cheap and they’ll play fine, MUX is fantastic but maybe a little overkill for what you need. Simplest way is using Bubble storage but depending on how many video’s you’re storing etc and whether or not you need to keep them for long periods of time, your Bubble storage may get eaten up quite quickly!

Hope some of that helps!
Paul

Strange… I’m trying to use the videoJS player instead of Vimeo, but it’s not working.

No list’s won’t work, only single video files are supported through that option (and the load media action). I haven’t implemented any type of playlist functionality in a way where a list of video files can be used.

Gotcha. It also seems to load really slow without Vimeo player. I will make due with the Vimeo option for now. Thank you for all the FANTASTIC support/response!!! (The fact that I get such response gives me great confidence in the plugin.)

No problems at all, just keep pestering me if you run into issues or need help etc. I’ll do my best to get back to you as soon as I can. Vimeo video’s may take a little longer to kick in at times, it’s because the MP4 version of the video has to be retrieved first. Most times it’s quick, sometimes a little longer than expected.

There is another way you can load Vimeo files through the plugin which might be a little quicker and it involves using the API request called Get data (vimeo) - Find that and read the parameter documentation, just shout if you need help with it.

1 Like

So the Execute Method = reset() , is working great. I added some conditionals that if " vimeo" isn’t in the url, to turn off the vimeo player. Testing with a YouTube URl and getting this error:
image

Here’s a look at my conditionals… am I missing anything that would cause the error? (It’s all still working and resetting… I just get an error when switching off the YT video.)
image

*Interesting point… if doesn’t throw the error if I start the video and then click “Next” which triggers the workflow. It only throws the error if I click “Next Video” without starting the YT video.

**NVM I think I solved it. I made the “Execute Method Reset” ONLY WHEN the url contains “vimeo.” It looks like the hard reset is only required for Vimeo… YT url will reset on it’s own.

Yeh so I would do what you can to get around these errors if you can. I’ve taken the vimeo and youtube plugins off Github (the official ones) and incorporated them into the videoJS player, I know a lot of code isn’t updated to work with the latest versions of videoJS, the vimeo one isn’t updated because it breaks their terms and conditions and I think the same for the Youtube one also. Annoying that they are, I’m not sure if I can do too much about all of them but if they give you real headaches let me know and I’ll try and figure out what’s going on.

1 Like

It seems the video player is not playing well with Bubble’s new responsive engine.

Here’s the layout settings on Bubble’s video player…

Here’s the layout settings on VideoJS Player…

*Since I don’t have the options to set a min/max for width/height… it’s creating trouble with responsiveness for side elements. (Example… I have left/right arrows on the side of the player that need to stay separated as it shrinks… once the parent group starts to shrink… the video player takes up all the space and just covers the other elements.)

**I realize the new responsive engine will change a ton of things… just trying to get ahead of the curve, so no rush. Let me know once you can take a look!

1 Like

Thanks for letting us know about that! It’s all a bit gibberish to me right now, I need to take a look at these new settings, which I will do as soon as I can!

2 Likes

Hello, I have a question.
I want to display a video which is in bubble database. Does it work with this plugin?

Hi @puhariki

Yep it will do that.

Just checking in here. Any updates/timelines to compatibility with the new responsive engine? (Is this something Bubble has to fix?)

Hi, afraid I haven’t had the time to take a look into it yet, I will do at some point though.
I’ve had a look at the new responsive engine and I can’t say I like the new options much. I’m not sure if Bubble are still making changes to it or not or what’s going on with it. I suppose it’s still in Beta mode so things could change.

Hey @pork1977gm ,

I’m having success recording, stopping, and uploading a video through the browser. But when I try to do the same through mobile (iphone) I get an error as soon as I hit “Stop”.
Mime type set to - video/webm;codecs=vp8

At first, I had disabled the recorder’s controls and triggered them through workflows with no success. Then I tried triggering through native recorder controls and that doesn’t work either.

I’ve been looking around this forum and can’t find a solution. Any reason this is happening?

I appreciate your feature-rich plug-in and your commitment to the Bubble community,
Thanks!
Aram

Hey Aram,

I’ll have a look at this for you sometime over the weekend and get back to you. Can I just ask, the error you’re referring to is the one seen in the screenshot right? If you can give us anymore info, it will help in trying to fix it. Either way, I’ll see if I can take a look tomorrow anyway, speak soon!

Paul

Thanks for getting back, Paul.
Yes, that is the Videojs Recorder throwing that error.

Here are the steps I’ve taken:

  1. trigger permissions
  2. start device

This opens up the camera within the browser and is ready to record. Ideally, I’d like to use the fullscreen native camera but haven’t looked into that yet.

Then when I hit record, the video recorder is started, everything is recording fine, but once I hit stop recording it crashes and that error is thrown in the recorder.

I’ve tried setting different mime types. Can’t get anything to work. So far everything is going well on desktop in terms of recording and uploading the video to the player. This problem only arises on mobile.

I’ve also tried on your example here on mobile and had the same results:

This is all the information I have unfortunately and I hope it makes things clearer. Thanks for getting back so quickly!