Prevent image from scrolling within Repeating groups

I need help figuring out how to prevent images from scrolling in RepeatingGroups.

I have images in repeating groups that scroll without scrolling the page scrolling, even though the images fit the group they are in. I would like the page to scroll with the user scrolls over the image.

Ex: Home | OneStopCamp. If you go over the image and scroll, you’ll notice that the images scrolls, but the page does not.

Has anyone seen this behavior? Any suggestions?

You want the individual image to be scrollable?

I don’t want the image to scroll at all. I only want the page to scroll.

I think you need to double check the size of the elements in use. If all images are displayed in a repeating group, so that only a single image is displayed in a single repeating group cell and you are not working with nested repeating groups, there has to be an issue with the size of the image or the group container.

When checking your site, I can see the little scroll that occurs if you hover and scroll over an individual image…I’ve never come across this in my 5+ years on Bubble in my development, so I assume, somehow the group that contains the image is expanding in height because the image is expanding the height of the container group.

What heights did you give the image and groups?

Here are the dimensions of the image. I have a RG-Image group, which contains an Image Group, which contains the image.

I have encountered such behavior before, but I could not determine the exact cause. I solved the problem by trying different settings for the dimensions and using the margins, so perhaps you can try adding a bottom margin to the image or the group that contains it, or perhaps you can uncheck the “fit height to content” option from the group that contains the Image.

It probably is. I don’t know where the setting is coming from. I started with this template - Home | Nalfe, which does not have the problem. I’ve double checked every setting from Image → GroupImage → RepeatingGroup Image and they all match. Still can’t put my finger on where the problem is.

I had tried this again and it didn’t solve the problem. Also, tried setting/unsetting “Scroll on overflow” and a few other settings. Nothing helps :worried:

check the settings of height for the repeating group.

responsive design is hard to master

TRUTH: “responsive design is hard to master”

This topic was automatically closed after 70 days. New replies are no longer allowed.