Privacy rule possible bug

Hi everyone,

I believe I just encountered a bug in the privacy rule.
Please have a look at the picture: this type of rule involving a list of users, only works if the list is not empty but there is at least one entry. If the list is empty, in my case, it just didn’t return results when searching.

Screenshot 2023-02-05 at 23.34.02

I don’t know that you can build compound rules like this, but also, shouldn’t you construct this logically the other-way-round?

The rule is labeled “blocked” but this is “not blocked”. Privacy rules are designed for simplicity. I think what you mean here two rules:

User Blocks Creator and
Creator Blocks User

Both of which would result in whatever-datatype-this-refers to to be unavailable.

1 Like

I tried 1000 ways and nothing worked, this is the only way that worked. But actually I just discovered this bug (I think), so it might work the other way around too, if I add at least one user to each list (blocking and blocked by)

edit: the label “blocked” is just something I wrote quickly while testing a way to make this work.

This topic was automatically closed after 14 days. New replies are no longer allowed.