Problem showing Google Calendar data in RG

I’m having trouble getting data from my calendar showing up in a RG. Right now, I’m just seeing if I can get data out of a google calendar into a RG and will then try to put into a database.

Here’s the edit view of the page for reference: buddytest | Bubble Editor

Here’s what I’ve done

  1. Set up authentication to my google calendar account. This looks like it’s working.

  2. I’ve set up a RG that looks like it’s correct but when I authenticate my calendar, no data shows up in the RG. This is the issue.

Here’s the configuration

A few questions

  1. Perhaps I haven’t set up the authentication. How would I test this?

  2. Assuming the authentication is correct, is there something I’m missing in getting calendar data to show up in the RG?

To test if the authentication is working I set up a piece of dynamic text that shows the “current users google calendar email address”. This never displays any information, even after I’ve authenticated.

This leads me to believe the google authentication is not working or is not returning any information.

Bubble community, any ideas on where I should look to figure this out in terms of courses, other forum posts, and/or general insights?

I had a quick look at this a few days ago … and came to much the same conclusion as you did…

“It ain’t working”.

Will have another look today, but it didn’t seem immediately obvious what the issue was.

So, I think you need to ask @levon or @vladlarin about the plugin, as it doesn’t seem quite right, but they know what they are doing, so am slightly confused.

The “scope” being used is the Google+ scope, when I don’t think will give you access to the Calendar.

I think it should be https://www.googleapis.com/auth/calendar

Also the user endpoint looks like it it is the people endpoint

I have used … and so has Gaby.

https://www.googleapis.com/calendar/v3/calendars/primary

You will notice that when you give your permission to Google, it does not ask for access to your calendar. It is really should, hence I don’t think you have access and it isn’t working. It is, however, authenticating you.

It should not take you long to code it up in the API Connector …

It looks like your App id/secret are set up correctly (you want the App Id rather than the API, which google very helpfully calls the Client Id in error messages).

This works and I have pulled back a list of calendars. You may need to look at how you pull back the primary one.

However, given the number of people using the plugin, I am maybe missing something in the use. But I couldn’t get it to work, beyond what you have already done i.e. authenticate only.

Hey all,
I’ve also tested this now
here is what I see on my authentication window

image

both access to user profile and calendars

I also see my email after I authenticate

the problem is here:

it should say email instead of id

that’s how Google knows which calendar to pull from.

I couldn’t change and test it since the app is in readonly. So please go ahead and try it and let us know how it goes.

About a month ago there was a problem with oauth2 apis and especially google apis that only the user who created and authenticated the plugin was able to use it (because only his email was accessible in the app otherwise the email could not be reached.)

but then together with Bubble we put these values and everything got sorted out

if you still can’t see your email please let us know and we’ll see what might be the problem.

By the way, here is the access scopes that we request
https://www.googleapis.com/auth/calendar https://www.googleapis.com/auth/plus.login
they are both Calendar and Google Plus
Thanks!
Levon Terteryan
Founder @ Zeroqode & Bubblewits
zeroqode-for-web-160x120
Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services

Why have you got the endpoint for the people API in there ?

That requires you enable that to get it to work … is that part of the work around for email ?

What I have noticed using my API connector is an occasional odd message from bubble when swapping authenticated emails on the same page, and it will give you the message that the API is now set up again.

p.s. I don’t get the email returned either.

as far as I remember we used People API to actually get the email and enable the offline access, otherwise it just woudln’t remember the user’s choice to allow access and would ask again after the token expires (50 minutes later).

we’ll check why the email is not returned.
Thanks,

by the way, is the latest version of the plugin installed? (nov 20-th when we resolved the issue with getting the email)

Hi all!

Looks like we found the reason for this strange behaviour (why it’s working for some and not working for others). Main point was that if the users’s Gmail was on G+ - it was working good, but was not pulling all the info in case the person did not have a G+ account.

Hence the confusion.

We’ll update the plugin and post in this thread as soon as it will be ready and tested.
Sorry for the inconvenience!

Ok, we’ve just pushed a fix that should solve the above mentioned issues.
Please update the plugin version and give it a try.
Thanks!

Levon Terteryan
Founder @ Zeroqode & Bubblewits
zeroqode-for-web-160x120
Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services

Thanks for the help guys. Glad I helped find a bug :slight_smile: I’m working on this tomorrow and will let you know how well I figure it out.

2 Likes