Problem SQL Database Connector

Hello I have a problem in SQL database connector, when I make the connection it is correct but when I make a query with a parameter it sends me an error. I have always done it like this in postgres and it works very well, but in this project it is with Microsoft SQL and it sends me this error

please help me

1 Like

Hi, :wave:t2: @maspaqueterias

Change in the query statement the $ for @

Tell me if it works :+1:t2::white_check_mark:

1 Like

Change your query statment of your where like,
WHERE Nombre=@Nombre.
Hope it works.

1 Like

Thank you! its works

1 Like

Hello Bubblers,
i am trying to connect to Microsoft for 3 days now.
If my string to connect to database with my code is

add name=“ERPConnection” connectionString=“Data Source=222.874.71.111, 15902;Initial Catalog=Dbase;User ID=so;password=pass@word” providerName=“System.Data.SqlClient” />

so to fit this string to bubble SQL connector i have put

and i have chosen database type to be Microsoft SQL. i am getting an error

Your connection string does not fit the standard string. It should look like mysql://

what is happening? what did i put wrong? my password has @ i have removed it and tried something else but i get same error.

1 Like

Hi :wave:t2:

Try adding this at the end of your connection string: :point_down:t2:


And also do not use any rare characters in your sql user password. I don’t know if the @ creates a conflict in the connection string.

Let me know if it works :+1:t2:

same error
Your connection string does not fit the standard string. It should look like mysql://

Umm, I have my sql database in azure and the port is 1433. I don’t know who can be in AWS but I did a quick search in google and I see the 1433 too.

maybe will work changing the port to 1433,
and without @ in the password

and with the


at the end works :+1:t2:

Let me try… thank you for trying to help.

1 Like

Ok :+1:t2:

What IP do I use to whitelist with my database so Bubble can connect to it it? MySQL won’t grant access without it. Is the IP address dynamic or static? If it’s dynamic, how do I find it and how often does it change?

Well in PostgreSQL I had to touch the pg_hba.conf file and put the IP of my machine where I have a database installed and I made a DMZ on my router to have external access!
I believe that in MySQL it should be something like that, you may have to release the IP of your server where your database is.

Hi, I’m same the problem with the connection external access database MYSQL, this setting following default, found all questions by forum not saw solution about this

What is the problem you are having (the specific error)?

Hi, the same problem connecting this topic, but in my case with MYSQL on server hostinger,(Connection issue: SQL Database Connector issue: Connection attempt failed: Current fiber timed out after 65000 ms) The support said about problem due to static ip my server

You have to be able to open up the mysql server to all IP addresses because Bubble does not offer static ip unless on a dedicated plan. In some cases this is not possible (depending upon your database hosting provider).