Forum Academy Marketplace Showcase Pricing Features

Problem with ZQ Fuzzy Search and autocomplete

@ZeroqodeSupport the plugin keeps returning no results for me on the Community page of my app. I have used the plugin without any issue on other pages but can’t get it to work here.

I have tried:

  1. Removing and adding back each element
  2. Changing the element data source to a Search and to a RG - neither worked
  3. Moving elements around

Here are screenshots of my setup and I have added you as a collaborator. Let me know what you think. Thanks!



image
image

Hello, @dowsett.justin
Thanks for the screenshot :pray:

Seems like the Fields to search are applied Privacy Rules, which could affect the performance of your app.
We kindly ask you to provide us ( you can send us a DM) the screenshots of the applied Privacy Rules for the “PersonalWrit” type and settings of your RG.

Thanks a lot!
Best regards,
Zeroqode Support Team

Hello, @rod.danan
Thanks for the screenshots and adding us to your app.

Actually, the issue of the Fuzzy Posts element was in the DataSource, indicated there.
Please note that our plugin searching through the DataBase, but not through the Repeating group, as in your case (each new post of your user is saved in the DataBase, and after it could be retrieved in the app).
In your case, the plugin refers to the Repeating Group on the page, so it reproduces the error.

Moreover, the DataSourse of your repeating group is a correct one, and the plugin element should have the same source of entries.

Once we changed the DataSource of the plugin element, the search feature started to perform correctly:


Hope it will help you :slightly_smiling_face:
Best regards,
Zeroqode Support Team

Hey Zeroqode. Thanks for the quick response. I should have specified that it was actually version-testing (not version-test) where the issue is happening. As you can see the layout is different in the pictures. The data source is set up that way in version-testing but still not working.

Hello, @rod.danan
Thanks for the concretization.

First of all, please provide us with the credentials for the account, which we can use for entering exactly this version of the application.
Despite the fact that we created a new account, we always were redirected to the Version-Test, not Testing.
Thus, for speeding up the process of investigation, please share with us the required credentials.

Also, we have some questions regarding your settings, since we suppose that exactly your page construction affects the plugin. The main pending point is using Reusable Element in the Group, which is also grouped by the Repeating Group.

Unfortunately, the probability that the plugin will work is quite low:
image

Please let us know why you are using the Reusable Post in the Repeating Group?
Actually, you just overlapping one content with the same content from the group.

Looking to hearing from you soon.
Best regards,
Zeroqode Support Team

Just DM’ed you log in info.

For the reusable element, I don’t understand why that would make a difference. I use reusable elements in almost every RepeatingGroup in my app and many of those have a working Fuzzy filter with it. Reusable elements mean that a Post will look the same no matter where it is viewed.

Since the reusable element is used to display a single result, why would a Fuzzy filter that searches for records be affected?

Hello, @rod.danan

Please check our reply in the DM messages. The root cause of the error was detected and fixed.

Hope it will help you.
Best regards,
Zeroqode Support team

Hello,

not sure if this is the right place to ask for help but I have a problem with the “ZQ Fuzzy Search & Autocomplete”.

It doesn’t show the 5 fields “Field To Search 1, 2, 3, 4, 5” follows the image of how it appears for me:

Has there been an update and removed these fields?

Hello, @domontic
Thanks for reaching out.

Please allow us to check the “Fields to search” option within the plugin’s code. We will do our best to revert with an update at the nearest time.
But until then, you can place the Text Elements within your RG, and indicate the Data Source for each element (like name, class, type and etc.):


It allows you to create the same functionality without indicating the “Fields to search” in the plugin element.

Best regards,
Zeroqode Support Team

1 Like

Hi, @ZeroqodeSupport

Thanks for the reply and help, only without those input fields the plugin returns error.
Here is the image with the error I receive:

thanks

Hello,

The fields have now appeared, it was a bubble problem, the substitution of elements also did not work. After reporting to the bubble team my case is now solved.

thank you

Hello, @domontic
Thanks for the information.

Our team reached the Bubble Team and this bug was fixed.
Now, all the Fields to Search are available and errors will not appear on your side.

We hope you will be satisfied with the use of this plugin.
Best regards,
Zeroqode Support Team

Hey, seems like the bug fix didn’t go through for all?
I still have the same issue.

Hello, @n.niklaus
Sorry for this inconvenience :pray:

Please try to remove the plugin element and install it once again on your page. All fields should appear on your side.

However, if the issue persists - please add our Support Team email to the list of collaborators to your application and provide us a link.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

We are looking to hear you soon.
Regards,
Zeroqode Support Team

Hello,

sorry to add a new topic but I really don’t understand why my Fuzzy Search & Autocomplete doesn’t find any result even when I simplify all the conditions.
You said that could come from the privicy rules? I see only that as a reason but even when every rules allows all fields in search it still doesn’t work, the fuzzy Search & Autocomplete element doesn’t find anything.
Could you help me?


rg condition

Hello, @cascam
Thanks for reaching out.

After analyzing your settings, we defined that you haven’t enabled this checkbox:

Please note that you need to set Text to match or to use matching from the input ( by adding the ID and enabling the mentioned checkbox) in order to receive the results.

Try it and let us know about your result.
Best regards,
Zeroqode Support team

Hi, yes I saw this mistake after posting (I tried to delete and re-add the element and forgot to check the box) but it doesn’t change anything, there is still no match.
I really don’t understand because on an other app I tried the same config and it works…

Hello, @cascam

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide us a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,
Zeroqode Support Team

it’s done, the page where I test the element is named “copy_test”

Hello, @cascam
Thanks for the provided access.

Please allow us to check your app and revert with our feedback at the nearest time. Thanks for your understanding.

Best regards,
Zeroqode Support team