Registrar cant add DNS records, only Nameservers

I registered a domain name in Guatemala, (.gt) very low fi. You have to call in if you need to make changes to your domain. No online admin panel.

So I did to instruct them to add the DNS records… turns out, they can only add nameservers! They “don’t have access” to DNS settings.

What to do?

Solved it.
For anyone having this curiosity: nameservers can be any nameserver.
I purchased the cheapest hosting plan I could find. Pointed the new domain to the hosting’s nameservers (in this case, namecheap). From there, I can now add the records.


I know how depressed you were when you found out you can only put nameserver and how happy you were when you found out about namecheap right? I felt the same :joy::joy::joy:


@despega @solinz happy to see I’m not the only one in this scenario.

I purchased a domain in Guyana (.gy) but the registrar is asking for 2 nameservers instead of a DNS record.

Did you purchase hosting from namecheap, configure the bubble app’s DNS records in namecheap then give the nameservers from namecheap to your domain registrar?

Would appreciate any help/pointers. Thanks in advance

To anyone coming after me, here’s how to do this on Namecheap:

Once you’re done, share the Namecheap nameservers with your registrar.
Waiting on my registrar to update my records.

Note: Namecheap also offers a FreeDNS service but i opted for the premium version ($4.88 USD/yr at the time of this post)

@despega I’m having issues connecting my bubble app with Namecheap. Can you please tell me how you resolved the issue? I’ve attached pictures of my DNS records. It would be great to know how you solved it

You don’t need to blur these records, they’re public anyway…

Have you waited 24 hours?

it worked now. thank you @georgecollier