Forum Academy Marketplace Showcase Pricing Features

Namecheap Domains [Solved]

I’ve tried to add my custom domain from namecheap.com, but with no success. I’ve added all the specified options in the advanced dns section, but bubble.is says that it cannot find my domain.

Has anyone used namecheap.com and if so how did you achieved setting a custom domain with it? Maybe guide on this would be a good thing to do.
Thanks!

For the host value on the TXT record, use “@”.

I’ve changed for the TXT record from “*” to “@”.

For the A record that is empty I must also use the “@” or the “*”?

The A records should be the values provided in the Bubble settings.

One of them is “www” and the other one is empty.

Your situation is a bit different than the one I had. Try this. For the one with www, put “www.appname”. For the empty one, put “appname”.

Ok, I guess now I have to wait for 24 hours. I’m not sure if it works. Does it take many hours to check this?

In my case, I waited less than 5 minutes. If you’re still having issues, contact Namecheap through their chat. That’s how mine was resolved. Then shoot an email to Bubble support if it’s still unresolved.

Ok. Thanks for your help! You’re awesome! :smiley_cat:

2 Likes

Just got my reply from Namecheap:

Eduard, as I see the domain bubble.is is not registered with us in your account and is using nameservers different to ours (ns1.dreamhost.com - ns3.dreamhost.com)

Thus, we do not have access to the DNS records of bubble.is domain name, since they are under control of your current host.

It is highly recommended that you contact your hosting provider in order for them to assist you with setting up the required records.

So I’d recommend you to contact your current DNS provider of bubble.is (dreamhost) to check if it’s possible to modify host records on their end.

They thought I own bubble.is :laughing:
Anyways they’ve helped me solve it. Now it works.

1 Like

If you don’t mind, could you share what the solution was if it wasn’t too specific to your situation. I anticipate having the same problem as an app of mine also has a blank A record.

1 Like

Yes, it would be really useful to share various DNS settings (still a dark art !) with various providers.

There is a very cool web page that shows DNS propagation around the globe. Will dig it out.

Classic developer line …

Me : “The site isn’t working”
Dev : “Ah, give it a few hours for the DNS changes to propagate”

:slightly_smiling:

1 Like

Namecheap Domain Manager:
For my case I’ve had the first A Record blank and the TXT Record blank.
I’ve set in namecheap the following DNS Records:

A Record: Host: “@” with the Value: “provided by bubble” (first empty A Record I had in bubble)
A Record: Host: “www” with the Value: “provided by bubble.is”
TXT Record: Host: “@” with the Value: “provided by bubble” (second empty TXT Record I had in bubble)
CNAME: Host: “provided by bubble” with the Value: “provided by bubble”
CNAME: Host “provided by bubble” with the Value: “provided by bubble”
CNAME: Host “provided by bubble” with the Value: “provided by bubble”

So replacing the blank with @ I guess does the trick. Now everything works fine.

4 Likes

I have a similar problem at the moment.

So at first I had a lot of entries in the domain section (2x A Records, 1x TXT, 3 CNAME)
I did not know which of these fields I have to populate in my domain name manager and just put everything in. It did not work, I fiddled around (too much I guess) and now my problem is that (no matter what I do) I get only two fields for A records. One is empty and the other is only “www”.

Also, eventhough my configuration in my domain name manager is not complete/correct I get the message that my app “is working and ready to go”. But actually it is still not available/reachable.

What should I do?

I have done this many times with Namecheap and it works every time. See the image below. You basically have two A records and three C Name records and you input what Bubble gives you.

2 Likes

thanks Renato!

My problem is that all I currently get in the bubble editor is this:

You may be looking in the wrong place… Under Domain & Email in your app, after you add a domain name, you get all the A Record and C Name keys you need. The difference is that on the blank Type A record, you enter in an @ at the host on NameCheap as previously illustrated.

1 Like

really weird…this is what I get now all the time when I enter my domain:

But in fact, it is not working. I would be happy if at least all the records (A, CNAME, TXT) would come back…
(Sorry for blurring, dont want to reveal my domain name to the internet as long as the app is in beta)

What level of subscription on Bubble do you have?

I am on the personal plan.