Repeating Group Not Displaying Dynamic Data on Preview

For some strange reason when I preview the page it shows blank. The Repeating Group does not show anything. Even though I have added data to the table in the db and I have linked it as the data source to the repeating group.
Please, how can I resolve this? I have attached some images. Thank you


Check the data type’s privacy settings

Hello @cmarchan
Ok, I have checked the Privacy settings of the Data types. What am I supposed to change? It still shows a blank.
Kindly see attached image.

Hi mate, did you manage to fix the problem with repeating group not showing anything?
please let me know how you fix that if you have as I’m having exactly same issue with my repeating group.
best of luck

Hi there, @pjmantoss… the way the rule is configured, the current user will only see things from the Clothes data type that they created in the application. If you want all users to be able to see all of the things in the Clothes data type, delete the rule altogether, and that should take care of it.

Note that you could have a rule that says users must be logged in to be able to see things, but at this point, just delete the rule to see if the data shows up.

Hope this helps.


@davoodi6 @pjmantoss

Complementing @mikeloc guidance and for the time being, perhaps you guys can go ahead and delete all privacy rules in your apps. This will enable you to see all data.

Once you are more familiar with Bubble and you want to revisit securing your apps’s data you can activate them.

It is tricky to build privacy rules. Here, an instructional video to get you started: :grinning:

1 Like


Click the trash icon to delete the privacy rule

@cmarchan @mikeloc
The issue has been resolved. After I deleted the Privacy Rules, The RepeatingGroup element started displaying all the data from the ‘Clothes’ table in the DB.
Thank you

for your help.


Hello @davoodi6
The issue has been resolved. The RepeatingGroup element now displays dynamic data from the DB after I deleted the Privacy Rules. Thank you for your help.

I had the same problem with the same solution,Thanks for your response.

Thanks Cmarchan for the video, very helpful information, appreciated.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.